Ask Your Question
0

glance error up on db_sync [closed]

asked 2014-09-19 06:43:10 -0500

Arumon gravatar image

Hi All,

I am installing glance (icehouse) on rhel 6.4 (Santiago) x86_64. I am using the database mysql. While trying to execute the db_sync command i end up with the below error. Please help.

#su -s /bin/sh -c "glance-manage db_sync" glance

/usr/lib64/python2.6/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.
  _warn("Not using mpz_powm_sec.  You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Arumon
close date 2015-02-25 05:00:07.922073

Comments

The output (provided above) is only a warning! Can you check whether the glance database is created (using the mysql client)?

unmesh-gurjar gravatar imageunmesh-gurjar ( 2014-09-19 07:10:20 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-09-19 09:27:37 -0500

rahulrajvn gravatar image

updated 2014-09-19 09:29:10 -0500

That is just warning the database would have been created with out any issue. If you want to remove this warning message you can comment out those messages.

perl -p -i -e "s/^(if _fastmath is not None .*:)/#\1/" /usr/lib64/python2.6/site-packages/pycrypto-2.6.1-py2.6-linux-x86_64.egg/Crypto/Util/number.py

perl -p -i -e "s/^(\s_warn.Not using mpz_powm_sec.*)/#\1/" /usr/lib64/python2.6/site-packages/pycrypto-2.6.1-py2.6-linux-x86_64.egg/Crypto/Util/number.py

If you want to make a fix try following the URL

link texthttps://ask.openstack.org/en/question...

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-19 06:43:10 -0500

Seen: 703 times

Last updated: Sep 19 '14