Ask Your Question
1

Why can my instances not ping host & vice versa? [closed]

asked 2014-09-19 06:26:48 -0600

mickt gravatar image

updated 2014-10-08 08:25:23 -0600

I've added this to the top so that it may save you reading through all that follows. I have as yet not achieved a fully working system comprising of icehouse with neutron on ubuntu after some weeks of effort. I have however achieved it on CentOS after two days. I'd advise those who are not tied to ubuntu as a host OS to use RHEL/CentOS and use packstack. :-) I will continue investigation on ubuntu when time allows and follow below.

I have installed OpenStack Icehouse on Ubuntu 14.04 LTS and configured neutron. I have configured external & internal networks, subnets and router etc. I can create instances and they can ping each other and external interface of qrouter etc.

I cannot ping beyond qrouter, e.g. host IP and beyond and I cannot ping instances from the host. I suspect that eth0 on host is still being used, where br-ex should be?

Anyone have some tips?

root@qa-openstack01:~# ifconfig
br-ex     Link encap:Ethernet  HWaddr 00:22:64:9b:38:46
          inet addr:10.10.12.7  Bcast:10.10.12.255  Mask:255.255.255.0
          inet6 addr: fe80::222:64ff:fe9b:3846/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:7047 errors:0 dropped:3 overruns:0 frame:0
          TX packets:3980 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:510845 (510.8 KB)  TX bytes:896241 (896.2 KB)

br-int    Link encap:Ethernet  HWaddr 52:d5:65:a9:ef:40
          inet6 addr: fe80::50e6:6bff:fecd:112a/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:79 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8257 (8.2 KB)  TX bytes:648 (648.0 B)

br-tun    Link encap:Ethernet  HWaddr fe:da:ad:8e:fc:43
          inet6 addr: fe80::707a:55ff:fefb:49d6/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:648 (648.0 B)

eth0      Link encap:Ethernet  HWaddr 00:22:64:9b:38:46
          inet6 addr: fe80::222:64ff:fe9b:3846/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7128 errors:0 dropped:41 overruns:0 frame:0
          TX packets:4257 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:656883 (656.8 KB)  TX bytes:936551 (936.5 KB)

eth1      Link encap:Ethernet  HWaddr 00:22:64:9b:58:8a
          inet addr:10.10.13.231  Bcast:10.10.13.255  Mask:255.255.255.0
          UP BROADCAST PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by mickt
close date 2015-01-07 03:32:19.916926

Comments

What says :

[root@icehouse1 ~(keystone_admin)]# nova secgroup-list-rules default
dbaxps gravatar imagedbaxps ( 2014-09-19 07:32:05 -0600 )edit

result added to main body above.

mickt gravatar imagemickt ( 2014-09-19 08:45:24 -0600 )edit

Could you post statement for createment external network && floating IP pool ?

dbaxps gravatar imagedbaxps ( 2014-09-19 09:04:28 -0600 )edit

What eth1 (10.10.13.231) is doing ? GRE or VXLAN tunnel IP && How many boxes setup ?
Please, post /etc/neutron/plugins/ml2/ml2_conf.ini. ovs-vsctl show looks as single box setup, otherwise it is not correct

dbaxps gravatar imagedbaxps ( 2014-09-19 09:45:00 -0600 )edit

File in main body above. eth1 is for future additional networks; I can delete if it assists with trouble shooting. GRE setup as per guide. This is setup for multinode but I do not yet have additional compute nodes setup.

mickt gravatar imagemickt ( 2014-09-19 09:58:06 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-09-19 09:10:26 -0600

mickt gravatar image

updated 2014-09-19 09:10:36 -0600

neutron net-create ext-net --shared --router:external=True

neutron subnet-create ext-net --name ext-subnet --allocation-pool start=10.10.12.231,end=10.10.12.239 --disable-dhcp --gateway 10.10.12.1 10.10.12.0/24

edit flag offensive delete link more
1

answered 2014-09-20 09:13:05 -0600

dbaxps gravatar image

updated 2014-09-29 04:12:19 -0600

Forced to use this field due to leack formatting options in comment fields :-

[root@icehouse1 ~(keystone_admin)]# cat /etc/neutron/metadata_agent.ini | grep -v ^$ | grep -v ^#
[DEFAULT]
debug = False
auth_url = http://192.168.1.127:35357/v2.0
auth_region = RegionOne
auth_insecure = False
admin_tenant_name = services
admin_user = neutron
admin_password = 5f11f559abc94440
nova_metadata_ip = 192.168.1.127
nova_metadata_port = 8775
metadata_proxy_shared_secret =227f7bbc8b6f4f74
metadata_workers = 0

Try to run from within your VM :

$curl  http://169.254.169.254/latest/meta-data/instance-id

Per your report

root@qa-openstack01:~# cat /etc/neutron/l3_agent.ini | grep -v ^$ | grep -v ^#

[DEFAULT]
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
use_namespaces = True
external_network_bridge = br-ex

Working version of l3_agent.ini

[root@icehouse1 ~(keystone_admin)]#cat /etc/neutron/l3_agent.ini | grep -v ^# | grep -v ^$
[DEFAULT]
debug = False
interface_driver =neutron.agent.linux.interface.OVSInterfaceDriver
use_namespaces = True
handle_internal_only_routers = True
external_network_bridge = br-ex
metadata_port = 9697
send_arp_for_ha = 3
periodic_interval = 40
periodic_fuzzy_delay = 5
enable_metadata_proxy = True
router_delete_namespaces = False

Make sure nova.conf has entries :-

[root@icehouse1 ~(keystone_admin)]# cat /etc/nova/nova.conf | grep -v ^$ | grep -v ^#|grep metadata
enabled_apis=ec2,osapi_compute,metadata
metadata_listen=0.0.0.0
metadata_listen_port=8775
metadata_workers=2
service_neutron_metadata_proxy=True
neutron_metadata_proxy_shared_secret=227f7bbc8b6f4f74
metadata_host=192.168.1.127

[root@icehouse1 ~(keystone_admin)]# neutron agent-list
+--------------------------------------+--------------------+-----------------------+-------+----------------+
| id                                   | agent_type         | host                  | alive | admin_state_up |
+--------------------------------------+--------------------+-----------------------+-------+----------------+
| 43fa28fb-46fa-4030-9f25-5da92847754f | Open vSwitch agent | icehouse2.localdomain | :-)   | True           |
| 471ab637-49eb-424b-b63e-3d03539150ac | Open vSwitch agent | icehouse1.localdomain | :-)   | True           |
| 495056c8-bb69-4bb4-b954-2398f49dd57a | Metadata agent     | icehouse1.localdomain | :-)   | True           |
| 76eb528d-2673-4ac2-936f-70157d46c566 | L3 agent           | icehouse1.localdomain | :-)   | True           |
| 8f1b4d6b-81df-4903-8a35-df9250143a8b | DHCP agent         | icehouse1.localdomain | :-)   | True           |
+--------------------------------------+--------------------+-----------------------+-------+----------------+
[root@icehouse1 ~(keystone_admin)]#  neutron router-list-on-l3-agent 76eb528d-2673-4ac2-936f-70157d46c566
+--------------------------------------+---------+-----------------------------------------------------------------------------+
| id                                   | name    | external_gateway_info                                                       |
+--------------------------------------+---------+-----------------------------------------------------------------------------+
| 4135e351-9ae4-4e89-9b23-7b131b2c4e6c | router3 | {"network_id": "295a5bba-c219-407f-830d-911cd2214349", "enable_snat": true} |
| 7ae6d151-7f95-4510-bd4f-7b7c56f20f3e | router5 | {"network_id": "295a5bba-c219-407f-830d-911cd2214349", "enable_snat": true} |
| ecf9ee4e-b92c-4a5b-a884-d753a184764b | router3 | null                                                                        |
+--------------------------------------+---------+-----------------------------------------------------------------------------+
edit flag offensive delete link more

Comments

What is your address 169.254.169.254?

mickt gravatar imagemickt ( 2014-09-20 09:55:50 -0600 )edit

Yes,169.254.169.254

dbaxps gravatar imagedbaxps ( 2014-09-20 10:06:48 -0600 )edit

curl: (7) couldn't connect to host

mickt gravatar imagemickt ( 2014-09-20 10:29:21 -0600 )edit

You don't have access to nova-metadata server, what causes cloud-init to fail and might be a core issue. View toubleshooting steps http://bderzhavets.blogspot.com/2014/...

dbaxps gravatar imagedbaxps ( 2014-09-20 10:53:29 -0600 )edit

Please , post nova.conf in your question.

dbaxps gravatar imagedbaxps ( 2014-09-22 08:11:49 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-19 06:26:48 -0600

Seen: 622 times

Last updated: Oct 08 '14