Ask Your Question
0

"permission denied" when trying to login to dash board

asked 2013-09-04 06:48:58 -0500

blazesurfer gravatar image

updated 2013-09-05 20:40:01 -0500

smaffulli gravatar image

When trying to login to dash board OSError: [Errno 13] Permission denied: '/usr/share/openstack-dashboard/static'

Any ideas?

the

wwwrun:www /usr/share/openstack-dashboard

edit retag flag offensive close merge delete

Comments

1

try "cd /usr/share/openstack-dashboard && mkdir static && chown webServerUser:webServerGroup static"

Tolik gravatar imageTolik ( 2013-09-04 11:16:12 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2013-09-04 15:38:06 -0500

blazesurfer gravatar image

ok turns out it was keystone related and required the static folder to be manaully created (suspect a rights issue with the user wwwrun not having rights to the location to create the static folder)

Thank you for your help guys. more questions to come in the near future

Regards

Scott

edit flag offensive delete link more
0

answered 2013-09-04 08:59:46 -0500

gmi gravatar image

You need to provide more information about your setup: - what operating system you are running and what version of Openstack is installed - where did you install from: distro packages or source - what installation instructions did you follow - any other symptoms, errors, etc

edit flag offensive delete link more

Comments

OK thanks gmi, OS Suse Linuk Enterprise 11 sp 3 - installed from distro packages the suse build services. using the openstack documentation as guide. Keystone installed and setup memcahced setup openstack-swift setup

blazesurfer gravatar imageblazesurfer ( 2013-09-04 15:30:17 -0500 )edit

apache error_log is dumping this now WARNING:openstack_auth.forms:Login failed for user "scottm". [error] DeprecationWarning: Translations in the project directory aren't supported anymore. Use the LOCALE_PATHS setting instead.DeprecationWarning: Authentication backends without a `supports_inactive_user` attribute are deprecated. Please define it in <class 'openstack_auth.backend.keystonebackend'="">.DEBUG:openstack_auth.backend:Beginning user authentication for user "scottm".

blazesurfer gravatar imageblazesurfer ( 2013-09-04 15:31:53 -0500 )edit

just noticed keystone log gives ERROR keystone.common.cms [-] Signing error: Unable to load certificate - ensure you've configured PKI with 'keystone-manage pki_setup' ERROR keystone.token.providers.pki [-] Unable to sign token

blazesurfer gravatar imageblazesurfer ( 2013-09-04 15:32:01 -0500 )edit
0

answered 2017-07-03 06:22:36 -0500

Rupesh Chowdary gravatar image

Check the file permission. In /usr/share/openstack-dashboard/static/dashboard check the json file permission. File permission should be 644.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-09-04 06:48:58 -0500

Seen: 683 times

Last updated: Jul 03