Deploying Designate on Fedora

asked 2014-09-16 11:54:56 -0600

sambol gravatar image

I'm having trouble deploying Designate. I keep getting "Failed to load transport driver 'rabbit'" no matter what I do to the config files. Has anyone had luck recently deploying Designate?

edit retag flag offensive close merge delete

Comments

I've tried that option for notification_driver and I've also tried the following:

notification_driver = designate.openstack.common.rpc.impl_qpid

python-amqp is installed and upgraded to the latest version.

Thank you...

sambol gravatar imagesambol ( 2014-09-16 13:29:23 -0600 )edit

What notification driver are you currently using in nova.conf?:

grep notification /etc/nova/nova.conf
mpetason gravatar imagempetason ( 2014-09-16 13:31:05 -0600 )edit

Maybe that's my problem? I'm trying to install just the Designate service in it's own VM, separate from the bare metal controller node.

sambol gravatar imagesambol ( 2014-09-16 13:34:06 -0600 )edit

Or you may be missing libraries it is expecting. I don't know the per-requisites. If you install it on one of your controllers does it have issues? You should be able to install services without pre-reqs on any server you want.

mpetason gravatar imagempetason ( 2014-09-16 13:35:35 -0600 )edit

I believe I had similar problems on the controller node when I tried, but it was a few weeks ago..

Here are some more details about the error:

oslo.messaging.transport.driverloadfailure: failed to load transport driver "rabbit" 
no oslo.messaging.drivers driver found
sambol gravatar imagesambol ( 2014-09-16 13:49:12 -0600 )edit