Openstack Havana Neutron: unable to get the ip address for instance virtual machine

asked 2014-09-15 08:32:15 -0500

rajcoumar gravatar image

3 Virtual machine. I am using the 3 ethernet cable. 1 for private network, another one for public network and last one for gre.

In Controller node, I didn't attach the 3rd ethernet cable. ie: gre

  1. Contoller node
  2. Compute node
  3. Network node

Publick network - Only internet purpose i enabled this interface. Because i want to install the packages.

In Controller node, I installed keystone, cinder, glance, nova. Two network interfaces enabled. Private network - eth0 : 10.10.10.100 Public network - eth1 : 192.168.2.150

In Compute node, I installed compute-kvm, python guestfs, neutron-plugin-openvswitch-agent and openvswitch-datapath-dkms. Two network interfaces enabled. Private network - eth0 : 10.10.10.101 Public network - eth1 : 192.168.2.151

Manually (no dhcp for this interface) I setup the ip address as static for 3rd network interfaces (gre) gre network - eth2 : 12.12.3.1 ( static ip address )

br-int (internal network) Added one ovs bridge adapter. ie: br-int (internal network)

In network node, I installed neutron-server, neutron-dhcp-agent, neutron-plugin-openvswitch-agent and neutron-l3-agent. Two network interfaces enabled. Private network - eth0 : 10.10.10.102 Public network - eth1 : 192.168.2.152

gre network - eth2 : 12.12.3.2 ( static ip address )

br-ex (external network) Added two ovs bridge adapters. ie: br-ex & br-int. After that, I added port for br-ex to eth0.

While launching a instance through horizon or nova boot command line, it launched and also it shows the ip address in the dashboard what I created in neutron subnet(30.0.0.0/24). But not in the launched instance vm. I login into the instance vm and checked, it doesn't have ip address.

edit retag flag offensive close merge delete

Comments

1

do you have any error in your neutron related log files on your network node and also on your compute node (usually they are in /var/log/neutron folder). If you find any error please paste it in order to let us help you.

Antonio G. gravatar imageAntonio G. ( 2014-09-15 08:48:24 -0500 )edit

Hi Antonio G. I pasted the errors.. http://paste.openstack.org/show/112056/

rajcoumar gravatar imagerajcoumar ( 2014-09-16 02:20:59 -0500 )edit

hello, anyone is there

rajcoumar gravatar imagerajcoumar ( 2014-09-17 05:06:00 -0500 )edit

Hi, from error logs it says that you do not have table neutron.agents in the db. Could you check if the db is totally empty?

If the openstack-dhcp is working correctly you should have a dnsmasq process on your network node. Try to find it out with ps -ax | grep dnsmasq

Antonio G. gravatar imageAntonio G. ( 2014-09-18 07:32:24 -0500 )edit

Could you repeat the networking installation phase as per documentation (Ubuntu / CentOS)

Antonio G. gravatar imageAntonio G. ( 2014-09-18 07:34:18 -0500 )edit