Ask Your Question
1

Virtulizaed Devstack does not work any more

asked 2014-09-14 17:37:25 -0500

Robert gravatar image

On OpenStack I have launched virtual machine Ubuntu, associated floating IP address and have installed DevStack on it.

That is why I said "Virtualized Devstack" and after half hour dashboard show me errors. I do not know how is that possible.

I now on the end when DevStack installation script ./stack.sh comes to an end it prompt you IP address of dashboard, password and so one.

The IP address that have been showen on the end was not right. So to acces to Devstack dasborad I jsut use associated IP address. Dashborad was working for half hour afther that it stoops. What colud be wrond?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-09-16 17:51:14 -0500

mpetason gravatar image

You need to configure Devstack to use qemu(not KVM) and every time you reference an IP address you have to use the private IP address. The Instance is not aware of the Floating IP address so it cannot listen on the floating IP. You could get around this by associating 0.0.0.0 with services so they listen on all ports.

edit flag offensive delete link more

Comments

Yes but virtual machine where I have installed DevStack has suport for vitrtualization so KVM should work fine.

Robert gravatar imageRobert ( 2014-09-17 09:50:34 -0500 )edit

Did you try anything with using the local IP address? I would still use Qemu if the option is given.

mpetason gravatar imagempetason ( 2014-09-17 10:11:50 -0500 )edit

I will try it later. How do you meand if I have trying anything with local IP address? What do you meand by local IP address? I have been give on the end of devstack some IP address which are not working. It works for five minutes then dashboard stop work, I logged on it from public network.

Robert gravatar imageRobert ( 2014-09-17 14:20:45 -0500 )edit

I must check IP address and so on.

Robert gravatar imageRobert ( 2014-09-17 14:22:42 -0500 )edit

Is the IP address you are giving it associated with the private IP address of the instance? It shouldn't be the floating IP address as the instance is not aware of the float since it's NAT'd.

mpetason gravatar imagempetason ( 2014-09-17 14:28:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-14 17:37:25 -0500

Seen: 75 times

Last updated: Sep 16 '14