Ask Your Question
1

admin user can't log in keystone

asked 2013-09-02 05:17:33 -0500

ArKam gravatar image

Hi everyone!

I'm back to OS Installation as we have to test Grizzly on our lab here.

For this test batch, I've 3 servers on my side, one which aim to be the CloudController and the both other servers which aim to be Compute/Storage and Network nodes.

All this fancy staff is running under a fresh and shinny Fedora 19 Schrodinger Cat Inet install. I've off course install all the required package and keystone seems to be working fine but indeed its not.

I don't know why, but if I try to authenticate on Horizon with the admin user which have the admin role on my demo tenant, Keystone seems to be unable to perform the authentication and seems to said that the admin user is not a member of the admin role, but when I inspect this using Keystone CLI everything seems to be OK.

I've to precise that I can't login on keystone CLI using the admin username neither.

So, if someone have time to help me on this issue, I'll be happy :D Of course, you'll find all Configuration information and debug output below:

http://paste.openstack.org/show/85BkgZgtmsliqfJfswYP/ (Keystone Configuration file)

http://paste.openstack.org/show/Wck76HX8ZBgTdWH59VAW/ (Keystone Command line results)

http://paste.openstack.org/show/3daHE1ltUzrXElUKv0F5/ (Keystone Debug output)

edit retag flag offensive close merge delete

Comments

Here is a little improvement, as I was double checking my installation, I noticed that keystone created SSL related files, so I decided to enable SSL and SIGNING part of the configuration file, here is the current output of my keystone request: http://paste.openstack.org/show/Y0vX49WTY9G95Ft3JaI2/%3C/p%3E (http://paste.openstack.org/show/Y0vX49WTY9G95Ft3JaI2/)

ArKam gravatar imageArKam ( 2013-09-02 05:33:28 -0500 )edit

As I go forward on my analysis, here is the output of the logs if I delete the SSL directory and remove the SSL Directive. It seems that Keystone is now SSL Only by default. http://paste.openstack.org/show/4qxszP9VKU5jQ4qdcxqm/%3C/p%3E (http://paste.openstack.org/show/4qxszP9VKU5jQ4qdcxqm/)

ArKam gravatar imageArKam ( 2013-09-02 06:45:45 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-02-09 12:37:34 -0500

yatin gravatar image

<<< but when I inspect this using Keystone CLI everything seems to be OK.

The keystone CLI is run using token authentication thats why it is working, it is nothing to deal with authentication is unsuccessful from horizon(because username and password is used while login to horizon dashboard).

<<< I've to precise that I can't login on keystone CLI using the admin username neither. check the role assigned to admin user using command: keystone user-list --user admin --tenant demo, and share the same here. Also if commands can not be run through CLI, horizon login would not succeed

Then, execute keystone commands with --debug option and share debug output

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-09-02 05:17:33 -0500

Seen: 1,232 times

Last updated: Feb 09 '16