Ask Your Question
0

devstack install failed: missing packages detected

asked 2014-09-11 17:57:12 -0500

aaa gravatar image

I get an error when I run ./stack.sh on rhel 6.5. The log claims that all packages have been already installed and then fails with error like this -

...
2014-09-11 22:19:55.839 | Package python-webob-1.2.3-8.el6.noarch already instal led and latest version
2014-09-11 22:19:55.839 | Package pyxattr-0.5.0-1.el6.x86_64 already installed a nd latest version
2014-09-11 22:19:55.839 | Package libxslt-devel-1.1.26-2.el6_3.1.x86_64 already installed and latest version
2014-09-11 22:19:55.839 | Nothing to do
2014-09-11 22:19:55.839 | ++ die 1111 'Missing packages detected'
2014-09-11 22:19:55.839 | ++ local exitcode=1
2014-09-11 22:19:55.839 | [Call Trace]
2014-09-11 22:19:55.839 | ./stack.sh:680:source
2014-09-11 22:19:55.839 | /home/ajayapte/openstack/devstack/tools/install_prereqs.sh:67:install_package
2014-09-11 22:19:55.839 | /home/ajayapte/openstack/devstack/functions-common:1055:real_install_package
2014-09-11 22:19:55.839 | /home/ajayapte/openstack/devstack/functions-common:1043:yum_install
2014-09-11 22:19:55.839 | /home/ajayapte/openstack/devstack/functions-common:1111:die
2014-09-11 22:19:55.842 | [ERROR] /home/ajayapte/openstack/devstack/functions-common:1111 Missing packages detected
2014-09-11 22:19:56.844 | Error on exit

The worlddump*.txt file has no information other than current processes and df output. When I print the list of packages it is trying to install, I see that all packages exist. My local.config file is the sample file that I copied from the documentation. Any idea as to where to look for error?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-09-22 00:54:36 -0500

tahder gravatar image

updated 2014-09-22 00:56:36 -0500

It was the same as I had experienced. I think it is related to repositories, as what I did disable some repositories (particularly the epel) and got the problem. If you take a look on the log, there will be something "No package xxx", that's why you also got that 'Missing packages detected'.

My remedies:

Clean the cache --> yum clean all
Re-enable it back in the file epel.repo (enabled=0 to enabled=1)-->  /etc/yum.repos.d/epel.repo
Rerun --> yum -y upgrade

If still got it try to remove the cloned directory
$sudo rm -rf /opt/stack

Then besure to add/edit on your local.conf or localrc, so it will redownload
RECLONE=yes
OFFLINE=False

Hope this will help.

edit flag offensive delete link more
0

answered 2016-01-11 02:57:51 -0500

Digvijay gravatar image

It happened with me too, so I followed these steps: 1. Find out package/s name in stack.sh.log starting with "No package XXX" 2. Install specific packages with dependencies manually 3. Re-run stack.sh

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-09-11 17:46:56 -0500

Seen: 2,030 times

Last updated: Sep 22 '14