Ask Your Question
1

cannot access `/opt/stack/keystone/ (Devstack)

asked 2013-09-01 22:52:59 -0600

didi_odi gravatar image

updated 2013-09-03 03:01:13 -0600

Jobin gravatar image

I have followed from devstack.org to deploy devstack on my VM (UBUNTU 12.04 LTS) When I execute ./stack.sh script in the VM, I get the following error.

tytable': 'PrettyTable>=0.6,<0.8', 'pystache': 'pystache', 'cffi': 'cffi', 'python-quantumclient': 'python-quantumclient>=2.2.0', 'openstack.nose-plugin': 'openstack.nose_plugin>=0.7', 'pyparsing': 'pyparsing>=1.5.7,<2.0', 'oslo.sphinx': 'oslo.sphinx', 'python-glanceclient': 'python-glanceclient>=0.9.0', 'python-ldap': 'python-ldap==2.3.13', 'flask': 'Flask>=0.10,<1.0', 'amqplib': 'amqplib>=0.6.1', 'selenium': 'selenium', 'feedparser': 'feedparser', 'mox': 'mox>=0.5.3', 'jinja2': 'Jinja2', 'httplib2': 'httplib2', 'happybase': 'happybase>=0.4', 'psycopg2': 'psycopg2', 'pbr': 'pbr>=0.5.21,<1.0', 'webob': 'WebOb>=1.2.3,<1.3', 'passlib': 'passlib', 'unittest2': 'unittest2', 'psutil': 'psutil>=0.6.1,<1.0', 'greenlet': 'greenlet>=0.3.2', 'nose': 'nose', 'flake8': 'flake8==2.0', 'discover': 'discover', 'nosehtmloutput': 'nosehtmloutput>=0.0.3', 'jsonschema': 'jsonschema>=1.3.0,!=1.4.0', 'qpid-python': 'qpid-python', 'fixtures': 'fixtures>=0.3.14', 'eventlet': 'eventlet>=0.13.0', 'pyopenssl': 'pyOpenSSL', 'pastedeploy': 'PasteDeploy>=1.5.0', 'redis': 'redis', 'django-openstack-auth': 'django_openstack_auth>=1.1.1', 'docutils': 'docutils==0.9.1', 'python-troveclient': 'python-troveclient', 'pysqlite': 'pysqlite', 'python-neutronclient': 'python-neutronclient>=2.2.3,<3', 'sphinxcontrib-httpdomain': 'sphinxcontrib-httpdomain', 'django-compressor': 'django_compressor>=1.3', 'msgpack-python': 'msgpack-python', 'lockfile': 'lockfile>=0.8', 'paste': 'Paste', 'pyyaml': 'PyYAML>=3.1.0', 'sqlalchemy-migrate': 'sqlalchemy-migrate>=0.7.2', 'boto': 'boto>=2.4.0', 'cliff-tablib': 'cliff-tablib>=1.0', 'wsgiref': 'wsgiref>=0.1.2', 'mox3': 'mox3>=0.7.0', 'routes': 'Routes>=1.12.3', 'requests': 'requests>=1.1', 'anyjson': 'anyjson>=0.3.3', 'pyasn1': 'pyasn1', 'pycadf': 'pycadf>=0.1.4', 'python-cinderclient': 'python-cinderclient>=1.0.5', 'nose-exclude': 'nose-exclude', 'alembic': 'alembic>=0.4.1', 'sphinxcontrib-pecanwsme': 'sphinxcontrib-pecanwsme>=0.2', 'kazoo': 'kazoo>=0.9,<=1.1', 'hgtools': 'hgtools # dependency of pytest-runner that is only in setup_requires', 'python-heatclient': 'python-heatclient>=0.2.3', 'jsonpath-rw': 'jsonpath-rw>=1.2.0,<2.0', 'testrepository': 'testrepository>=0.0.17', 'testscenarios': 'testscenarios>=0.4', 'testresources': 'testresources>=0.2.4', 'swift': 'swift', 'dnspython': 'dnspython>=1.9.4', 'pyzmq': 'pyzmq==2.2.0.1', 'warlock': 'warlock>=1.0.1,<2', 'python-novaclient': 'python-novaclient>=2.12.0', 'websockify': 'websockify>=0.5.1,<0.6', 'sqlalchemy': 'SQLAlchemy>=0.7.8,<=0.7.99', 'simplejson': 'simplejson>=2.0.9', 'pylint': 'pylint==0.25.2', 'iso8601': 'iso8601>=0.1.4', 'pytz': 'pytz>=2010h', 'pecan': 'pecan>=0.2.0', 'testtools': 'testtools>=0.9.32', 'nosexcover': 'nosexcover', 'oauth2': 'oauth2', 'pyghmi': 'pyghmi', 'wsme': 'WSME>=0.5b2', 'django-nose': 'django-nose', 'hacking': 'hacking>=0.5.6,<0.8', 'dogpile.cache': 'dogpile.cache>=0.5.0', 'configobj': 'configobj', 'mysql-python': 'MySQL-python', 'pysendfile': 'pysendfile==2.0.0', 'suds': 'suds>=0.4', 'pip': 'pip>=1.4', 'jsonrpclib': 'jsonrpclib', 'xattr': 'xattr>=0.4', 'paramiko': 'paramiko>=1.8.0', 'lxml': 'lxml>=2.3', 'babel': 'Babel>=0.9.6', 'six': 'six<1.4.0', 'webtest': 'WebTest==1.3.3', 'jsonpatch': 'jsonpatch>=1.1', 'kombu': 'kombu>=2.4.8', 'cheetah': 'Cheetah>=2.4.4', 'pymongo': 'pymongo>=2.4', 'pam': 'pam>=0.1.4', 'mock': 'mock>=1.0', 'python-swiftclient': 'python-swiftclient>=1.5', 'wheel': 'wheel', 'python-keystoneclient': 'python-keystoneclient>=0.3.2', 'hp3parclient': 'hp3parclient>=2.0,<3.0 ...
(more)
edit retag flag offensive close merge delete

Comments

It seems like you pasted only the a part of the error message. If it is, please paste the complete error trace that comes up when you execute ./stack.sh, it would help in tracking down the root cause.

Jobin gravatar imageJobin ( 2013-09-02 04:00:44 -0600 )edit

Ohh I'm sorry.

didi_odi gravatar imagedidi_odi ( 2013-09-02 16:41:12 -0600 )edit

4 answers

Sort by ยป oldest newest most voted
3

answered 2013-09-04 04:13:29 -0600

Sirushti Murugesan gravatar image

updated 2013-09-05 20:59:39 -0600

It seems like the error lies here

  • git clone https://github.com/openstack/keystone.git /opt/stack/keystone Cloning into '/opt/stack/keystone'... remote: Counting objects: 29716, done. remote: Compressing objects: 100% (12796/12796), done. error: RPC failed; result=18, HTTP code = 200B | 120 KiB/s fatal: The remote end hung up unexpectedly fatal: early EOF

Which means the clone of the repository failed and thus leading to missing files which DevStack needs.

A quick workaround would be to do

cd /opt/stack/

and

git clone https://github.com/openstack/keystone.git

But this StackOverflow thread here seems more like the better solution:-

You can then run ./stack.sh again.

edit flag offensive delete link more

Comments

Thanks bro it works.

didi_odi gravatar imagedidi_odi ( 2013-09-14 00:55:40 -0600 )edit
1

answered 2013-09-03 23:55:19 -0600

Edward Zhang gravatar image

check if the directory of /opt/stack/keystone/*.egg-info exists and you have the access of this directory. If YES, run this command to build the egg:

sudo python setup.py build

edit flag offensive delete link more

Comments

Thx bro...

didi_odi gravatar imagedidi_odi ( 2013-09-20 01:21:31 -0600 )edit
0

answered 2015-11-05 22:15:35 -0600

shashidhar gravatar image

Try the stable version of Tempest (which is by default now "Kilo" release), this may work out...

$ git clone -b stable/juno https://github.com/OpenStack-dev/devs...

Cloning into 'devstack'... remote: Counting objects: 28160, done. remote: Compressing objects: 100% (14/14), done. remote: Total 28160 (delta 3), reused 0 (delta 0), pack-reused 28146 Receiving objects: 100% (28160/28160), 9.59 MiB | 6.00 KiB/s, done. Resolving deltas: 100% (19543/19543), done. Checking connectivity... done.

edit flag offensive delete link more
0

answered 2013-09-01 23:04:14 -0600

Yaguang gravatar image

try to run python setup.py install in keystone directroy then rerun stack.sh

edit flag offensive delete link more

Comments

I'm sorry, I was a novice in openstack (devstack) can you guide me how to run python setup.py and install in keystone directroy. Thanks.

didi_odi gravatar imagedidi_odi ( 2013-09-01 23:23:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-09-01 22:52:59 -0600

Seen: 2,116 times

Last updated: Nov 05 '15