Ask Your Question
3

unable to install glance-client in centos

asked 2014-09-11 01:14:21 -0600

lafada gravatar image

I am trying to install glance client in my virtual environment and its giving error,

[root@localhost root]$ pip install "python-glanceclient>=0.13.1"
Downloading/unpacking python-glanceclient>=0.13.1
  Downloading python_glanceclient-0.14.0-py2.py3-none-any.whl (82kB): 82kB downloaded
Requirement already satisfied (use --upgrade to upgrade): requests>=1.1 in ./.venv/lib/python2.6/site-packages (from python-glanceclient>=0.13.1)
Requirement already satisfied (use --upgrade to upgrade): python-keystoneclient>=0.9.0 in ./.venv/lib/python2.6/site-packages (from python-glanceclient>=0.13.1)
Requirement already satisfied (use --upgrade to upgrade): Babel>=1.3 in ./.venv/lib/python2.6/site-packages (from python-glanceclient>=0.13.1)
Downloading/unpacking pyOpenSSL>=0.11 (from python-glanceclient>=0.13.1)
  Downloading pyOpenSSL-0.14.tar.gz (128kB): 128kB downloaded
  Running setup.py (path:/home/nileshkumar-govindbhai.patel/workspaces/gozer/horizon/.venv/build/pyOpenSSL/setup.py) egg_info for package pyOpenSSL
    warning: no previously-included files matching '*.pyc' found anywhere in distribution
    no previously-included directories found matching 'doc/_build'
Requirement already satisfied (use --upgrade to upgrade): six>=1.7.0 in ./.venv/lib/python2.6/site-packages (from python-glanceclient>=0.13.1)
Requirement already satisfied (use --upgrade to upgrade): pbr>=0.6,!=0.7,<1.0 in ./.venv/lib/python2.6/site-packages (from python-glanceclient>=0.13.1)
Requirement already satisfied (use --upgrade to upgrade): PrettyTable>=0.7,<0.8 in ./.venv/lib/python2.6/site-packages (from python-glanceclient>=0.13.1)
Downloading/unpacking warlock>=1.0.1,<2 (from python-glanceclient>=0.13.1)
  Downloading warlock-1.1.0.tar.gz
  Running setup.py (path:/home/nileshkumar-govindbhai.patel/workspaces/gozer/horizon/.venv/build/warlock/setup.py) egg_info for package warlock
Requirement already satisfied (use --upgrade to upgrade): argparse in ./.venv/lib/python2.6/site-packages (from python-glanceclient>=0.13.1)
Requirement already satisfied (use --upgrade to upgrade): pytz>=0a in ./.venv/lib/python2.6/site-packages (from Babel>=1.3->python-glanceclient>=0.13.1)
Downloading/unpacking cryptography>=0.2.1 (from pyOpenSSL>=0.11->python-glanceclient>=0.13.1)
  Downloading cryptography-0.5.4.tar.gz (320kB): 320kB downloaded
  Running setup.py (path:/home/nileshkumar-govindbhai.patel/workspaces/gozer/horizon/.venv/build/cryptography/setup.py) egg_info for package cryptography
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    Package libffi was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libffi.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libffi' found
    c/_cffi_backend.c:13:17: error: ffi.h: No such file or ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-09-11 02:01:33 -0600

lafada gravatar image

I solved by installing libffi and libffi-devel

My actual problem is that I don't have libffi installed. I can see hundreds of messages about not being able to find libffi in the setup steps, and getting C compiler errors trying to include ffi.h, and so on. So, what I need to do is install it.

This is a C library, not a Python library. My platform may have a package for it that I can install with yum or apt or brew or port or whatever; if not, I can download it and install it manually. (IIRC, you can just ./configure && make install, but read the docs.) On some platforms, I may also need a libffi-devel or libffi-dev or libffi-libs or similar package.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-11 01:14:21 -0600

Seen: 898 times

Last updated: Sep 11 '14