Ask Your Question
0

failed to install RDO [closed]

asked 2014-09-09 03:53:41 -0500

Wang Zheng gravatar image

updated 2014-09-09 04:16:42 -0500

dbaxps gravatar image

Hi all, I got an error while installing RDO on CentOS7, I have disabled firewall and selinux. Below is details of error message, would somebody can help on this?

Installing Dependencies                           [ ERROR ]

ERROR : Failed to run remote script, stdout: no package provides puppet
Loaded plugins: fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
 * base: mirrors.pubyun.com
 * epel: mirrors.ustc.edu.cn
 * extras: mirrors.pubyun.com
 * updates: mirrors.pubyun.com
19 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package puppet.noarch 0:3.6.2-3.el7 will be installed
--> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: facter >= 1.6.6 for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: rubygem(rgen) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby(shadow) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-3.6.2-3.el7.noarch
--> Processing Dependency: ruby(augeas) for package: puppet-3.6.2-3.el7.noarch
--> Running transaction check
---> Package facter.x86_64 0:2.0.1-2.el7 will be installed
---> Package hiera.noarch 0:1.3.4-1.el7 will be installed
---> Package libselinux-ruby.x86_64 0:2.2.2-6.el7 will be installed
---> Package ruby-augeas.x86_64 0:0.5.0-1.el7 will be installed
---> Package ruby-shadow.x86_64 0:1.4.1-23.el7 will be installed
---> Package rubygem-rgen.noarch 0:0.6.6-2.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                 Arch           Version              Repository    Size
================================================================================
Installing:
 puppet                  noarch         3.6.2-3.el7          epel         1.2 M
Installing for dependencies:
 facter                  x86_64         2.0.1-2.el7          epel          86 k
 hiera                   noarch         1.3.4-1.el7          epel          25 k
 libselinux-ruby         x86_64         2.2.2-6.el7          base         127 k
 ruby-augeas             x86_64         0.5.0-1.el7          epel          23 k
 ruby-shadow             x86_64         1.4.1-23.el7         epel          14 k
 rubygem-rgen            noarch         0.6.6-2.el7          epel          84 k

Transaction Summary
================================================================================
Install  1 Package (+6 Dependent packages)

Total download size: 1.6 M
Installed size: 5.1 M
Downloading packages:
Public key for hiera-1.3.4-1.el7.noarch.rpm is not installed

stderr: Warning: Permanently added '192.168.1.13' (ECDSA) to the list of known hosts.
+ trap t ERR
+ rpm -q --whatprovides puppet
+ yum install -y puppet
warning: /var/cache/yum/x86_64/7/epel/packages/hiera-1.3.4-1.el7.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 352c64e5: NOKEY
Traceback (most recent call last):
  File "/usr/libexec/urlgrabber-ext-down", line 75, in <module>
    main()
  File "/usr/libexec/urlgrabber-ext-down", line 61, in main
    fo = PyCurlFileObject(opts.url, opts.filename, opts)
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1258, in __init__
    self._do_open()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1589, in _do_open
    self._do_grab()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1723, in _do_grab
    self._do_perform()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1517, in _do_perform
    raise KeyboardInterrupt
KeyboardInterrupt


Exiting on user cancel
++ t
++ exit 1

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Wang Zheng
close date 2014-09-22 00:45:44.767911

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-09-09 04:27:03 -0500

dbaxps gravatar image

updated 2014-09-09 07:48:22 -0500

Install package manually

    # yum install -y puppet  

    (start service as well)

    # systemctl start puppet
    # systemctl status puppet

Rerun packstack --answer-file=./answer-file-previous.txt

edit flag offensive delete link more
1

answered 2014-09-09 05:37:56 -0500

SGPJ gravatar image

Issue could be with puppet installation, Instead of trying Packstack directly, try to install puppet first on base OS and use same answer file.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-09-09 03:53:41 -0500

Seen: 1,916 times

Last updated: Sep 09 '14