How to add physical port e.g. eth1 to br-ex with opendaylight?

asked 2014-09-08 15:35:57 -0600

updated 2014-09-09 15:28:39 -0600

Hi All,

I'm trying to configure neutron with odl. All seems to be OK, except l3. Adding port eth1 to br-ex causes connection lost. I can see incoming packets on eth1 but not on br-ex. I want an IP configured on br-ex and without odl this configuration has been working. What am I doing wrong? Does odl requires some additional flow configuration? Should I use provider mappings or something instead of br-ex?
Any help would be appreciated.

[root@centos7 ~]# cat /etc/sysconfig/network-scripts/ifcfg-br-ex

DEVICE="br-ex"
BOOTPROTO="none"
DNS1="8.8.8.8"
GATEWAY=192.168.251.254
IPADDR=192.168.250.210
NETMASK=255.255.254.0
ONBOOT="yes"
TYPE="OVSBridge"
DEVICETYPE="ovs"

[root@centos7 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1

DEVICE=eth1
ONBOOT="yes"
IPV6INIT=no
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE=br-ex
PROMISC=yes

[root@centos7 ~]# ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether a6:dc:0f:e9:92:e1 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global eth0
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000
    link/ether 4a:59:82:b7:65:00 brd ff:ff:ff:ff:ff:ff
4: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN 
    link/ether a6:9c:09:ea:bf:5c brd ff:ff:ff:ff:ff:ff
6: br-int: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
    link/ether ea:e5:c0:68:bf:43 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::8087:50ff:fe35:f254/64 scope link 
       valid_lft forever preferred_lft forever
7: br-tun: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
    link/ether 46:f2:a9:cd:93:43 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::2c1c:8ff:fe06:77ee/64 scope link 
       valid_lft forever preferred_lft forever
8: br-ex: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
    link/ether e6:4d:4c:3f:58:41 brd ff:ff:ff:ff:ff:ff
    inet 192.168.250.210/23 brd 192.168.251.255 scope global br-ex
       valid_lft forever preferred_lft forever

[root@centos7 ~]# ovs-vsctl show

a9be1cad-a85f-48ce-be12-c0f09c719994
    Manager "tcp:10.0.0.1:6640"
        is_connected: true
    Bridge br-ex
        Controller "tcp:10.0.0.1:6633"
            is_connected: true
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth1"
            Interface "eth1"
                type: external
    Bridge br-int
        Controller "tcp:10.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port br-int
            Interface br-int
                type: internal
    Bridge br-tun
        Controller "tcp:10.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port br-tun
            Interface br-tun
    ovs_version: "2.0.0"
edit retag flag offensive close merge delete

Comments

in my understanding, there should be no difference. ODL is just another tool through which neutron speaks with OVS (as alternative to openvswitch-agent). If you also have an installation without ODL, can you compare OVS flows (ovs-vsctl dump-flows) in both of them ?

T u l gravatar imageT u l ( 2014-09-10 15:35:47 -0600 )edit

Hi @laboshinl, am also having similar issue, what needs to be modified for ifcfg-br-ex or ifcfg-eth1. In my case after adding eth interface to br-ex during odl integration, neutron-openvswitch agent is becoming active by itself. Please suggest.

Praveen N gravatar imagePraveen N ( 2016-09-08 23:25:22 -0600 )edit