Ask Your Question
1

Unable to login into Horizon console - Something went wrong

asked 2014-09-05 03:42:55 -0600

EgilsK gravatar image

updated 2014-09-05 17:33:54 -0600

smaffulli gravatar image

When logging into Horizon console, i'm getting error:

Something went wrong!
An unexpected error has occurred. Try refreshing the page. If that doesn't help, contact you local administrator

Deployed Helion version 1.3 according to guide here "HP Helion OpenStack® Community Virtual Installation and Configuration" Single hardware host with 100GB RAM running Ubuntu 14.04.1. Deployment finished successfully.

Tried restarting apache in controller VM, restarting controller VM itself - didn't help. I'm new to Helion and OpenStack. Any tips regarding where and what to check?

edit retag flag offensive close merge delete

Comments

Is this happened immediately after installation or after some time?

Ramunas gravatar imageRamunas ( 2014-09-05 04:37:44 -0600 )edit

Immediately after deployment. I was never able to login into Horizon successfully. Tried to redeploy whole thing, same.

EgilsK gravatar imageEgilsK ( 2014-09-05 05:13:51 -0600 )edit

Check the logs, look for more details there. Edit your question, don't add comments (make the question more complete and easy to read).

smaffulli gravatar imagesmaffulli ( 2014-09-05 17:34:30 -0600 )edit

check apache error log

leethaoqn gravatar imageleethaoqn ( 2014-09-06 04:13:47 -0600 )edit

Try to run installation from scratch.

Ramunas gravatar imageRamunas ( 2014-09-07 04:55:30 -0600 )edit

2 answers

Sort by » oldest newest most voted
2

answered 2014-09-07 05:34:56 -0600

SGPJ gravatar image

check all of openstack services are running, restart and see.

edit flag offensive delete link more

Comments

can you say which services Considered ?

RezaER gravatar imageRezaER ( 2015-01-28 04:30:58 -0600 )edit
1

answered 2014-09-08 06:56:59 -0600

EgilsK gravatar image

Fixed by restarting services on Controller like described here https://docs.hpcloud.com/helion/openstack/install-beta/prereqs/ (https://docs.hpcloud.com/helion/opens...)

os-refresh-config service mysql restart os-refresh-config service neutron-dhcp-agent restart service neutron-l3-agent restart service neutron-metadata-agent restart service neutron-openvswitch-agent restart service neutron-server restart

Noticed that cannot ping Controller IP from physical host after this. Fixed by restarting networking:

service networking restart

I can login into Horizon console and see demo instance in Overview tab.

However when switching to Instance tab, no instances are displayed and error pops up in upper right corner:

Error: Unable to retrieve instances.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-05 03:41:56 -0600

Seen: 3,115 times

Last updated: Sep 07 '14