Ask Your Question
0

My instance can ping the outside world, why doesn't a browser connect? [closed]

asked 2014-09-04 07:31:38 -0500

capsali gravatar image

updated 2014-09-04 12:50:05 -0500

nickchase gravatar image

Hi,

As the title says, i'm having problem with browsing from instances.

I can ping the outside world, either by ip or by name.

The problem is when i try to use the browser. Only two addresses work : the default IE homepage, msn.com and bing search. Everything else hangs and i don't receive any errors. It just sits at connecting or receiving data.

I can't help but think that this is a security group matter but i don't know what to activate. I tried opening some ports with no luck.

Also i can even make a pptp vpn in windows instance and connect to it from the outside world. This was simple because i knew i had to open port 1723 and add port number 47(GRE).

Can anybody tell me how i can make this work? Is anybody else troubled by this?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by capsali
close date 2014-09-04 15:10:08.005507

Comments

Are you running GRE system with MTU 1500 at VM's eth0 ?
Then run ifconfig eth0 mtu 1454 up.

dbaxps gravatar imagedbaxps ( 2014-09-04 07:38:57 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-09-04 07:40:58 -0500

dbaxps gravatar image

updated 2014-09-04 08:18:01 -0500

Are you running GRE system with MTU 1500 at VM's eth0 ?
Then run ifconfig eth0 mtu 1454 up.

System tuning

[root@dfw02 neutron(keystone_admin)]$ cat dhcp_agent.ini | grep -v ^# | grep -v ^$
[DEFAULT]
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
handle_internal_only_routers = TRUE
external_network_bridge = br-ex
ovs_use_veth = True
use_namespaces = True
dnsmasq_config_file = /etc/neutron/dnsmasq.conf

[root@dfw02 neutron(keystone_admin)]$ cat  dnsmasq.conf
log-facility = /var/log/neutron/dnsmasq.log
log-dhcp
dhcp-option=26,1454
edit flag offensive delete link more

Comments

I'm not sure i understand!

If u are refering to set the /etc/neutron/dnsmasq-neutron.conf with the value dhcp-option-force=26,1454 following documentation, i did. Should i set the mtu to the compute host and network host or in the VM?

capsali gravatar imagecapsali ( 2014-09-04 07:51:08 -0500 )edit

Post report ifconfig on your VM .

dbaxps gravatar imagedbaxps ( 2014-09-04 07:54:09 -0500 )edit

it's a windows 2012 instance :) I set the mtu manually in the VM but no luck.

capsali gravatar imagecapsali ( 2014-09-04 07:55:18 -0500 )edit

Post ipconfig report.

dbaxps gravatar imagedbaxps ( 2014-09-04 07:59:28 -0500 )edit

Launch standard ubuntu cloud image and make sure you can ssh to it via ssh keypair.
https://cloud-images.ubuntu.com/trust...
- trusty-server-cloudimg-amd64-disk1.img Then run :
$ curl lxer.com

dbaxps gravatar imagedbaxps ( 2014-09-04 08:03:30 -0500 )edit
1

answered 2014-09-04 12:40:38 -0500

alexpilotti gravatar image

We added recently MTU handling in cloudbase-init, so if you are running a recent version it will automatically pick up the MTU from the DHCP server.

https://github.com/cloudbase/cloudbase-init

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-04 07:31:38 -0500

Seen: 751 times

Last updated: Sep 04 '14