Ask Your Question
0

installation of packstack on FC20 fails with libselinux-ruby dependency

asked 2014-09-03 06:41:54 -0600

I am following the instructions at https://openstack.redhat.com/Quickstart . packstack --allinone tries to install puppet, which depends on rubygem-json. Installing the latter fails because the libselinux-ruby package on my system is too recent:

Error: Package: libselinux-ruby-2.1.13-19.fc20.x86_64 (fedora)
           Requires: libselinux = 2.1.13-19.fc20
           Installed: libselinux-2.2.1-6.fc20.i686 (installed)
               libselinux = 2.2.1-6.fc20
           Available: libselinux-2.1.13-19.fc20.i686 (fedora)
               libselinux = 2.1.13-19.fc20

I am running Fedora 20:

# cat /etc/fedora-release 
Fedora release 20 (Heisenbug)
# uname -a
Linux 5220.home 3.15.10-200.fc20.x86_64 #1 SMP Thu Aug 14 15:39:24 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Any suggestions what to do?

edit retag flag offensive close merge delete

Comments

Thanks for pointing this out; I had not seen it. The 32-bit libraries are for a 32-bit applicatin, but why doesn't the 64-bit version, which is also installed, appear in this error message. As I have fundamental networking problems on this system, they need to be fixed first.

Bernd Bausch gravatar imageBernd Bausch ( 2014-09-04 06:19:34 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-09-03 08:13:58 -0600

dbaxps gravatar image
I did this install just yesterday with no problems.
[root@icehouse1 ~]# rpm -qa | grep libselinux-ruby
libselinux-ruby-2.2.1-6.fc20.x86_64
You have 
Installed: libselinux-2.2.1-6.fc20.i686

It's strange for 64 bit fedora release
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-03 06:41:54 -0600

Seen: 99 times

Last updated: Sep 03 '14