neutron running. However it’s not listening port 9696

asked 2014-09-03 02:24:27 -0500

jaylee gravatar image

updated 2014-09-13 10:09:04 -0500

lafada gravatar image

why? i installed openstack from http://docs.openstack.org/icehouse/in...

finally, service neutron-server restart is ok

but that port is not listening(9696)

help me

/etc/neutron/neutron.conf

[DEFAULT]
debug = True
state_path = /var/lib/neutron
lock_path = $state_path/lock
core_plugin = neutron.plugins.ml2.plugin.Ml2Plugin
core_plugin = ml2
service_plugins = router
allow_overlapping_ips = True
auth_strategy = keystone
rpc_backend = neutron.openstack.common.rpc.impl_kombu
rabbit_host = controller
rabbit_password = 1212
notification_driver = neutron.openstack.common.notifier.rpc_notifier
notify_nova_on_port_status_changes = True
notify_nova_on_port_data_changes = True
nova_url = http://controller:8774/v2
nova_admin_username = nova
nova_admin_tenant_id = a855f5efc3054dc8921d8c6cf0beb7cd
nova_admin_password = 1212
nova_admin_auth_url = http://controller:35357/v2.0
[quotas]
[agent]
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf
[keystone_authtoken]
auth_uri = http://controller:5000
auth_host = controller
auth_protocol = http
auth_port = 35357
admin_tenant_name = service
admin_user = neutron
admin_password = 1212
signing_dir = /var/lib/neutron/keystone-signing
[database]
connection = mysql://neutron:1212@controller/neutron
[service_providers]
service_provider=LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default
service_provider=VPN:openswan:neutron.services.vpn.service_drivers.ipsec.IPsecVPNDriver:default
edit retag flag offensive close merge delete

Comments

can you please check if the neutron process is still running using "ps -aF | grep neutron*" command.

sushma-korati gravatar imagesushma-korati ( 2014-09-03 04:34:11 -0500 )edit

i checked root@controller# ps -ef | grep neutron-server neutron 376 1 0 14:58 ? 00:00:00 /usr/bin/python /usr/bin/neutron-server --config-file /etc/neutron/neutron.conf --log-file /var/log/neutron/server.log --config-file /etc/neutron/plugins/ml2/ml2_conf.ini

jaylee gravatar imagejaylee ( 2014-09-10 20:38:52 -0500 )edit

ok.. Check neutron-server.log file to find log like below: INFO neutron.service [-] Neutron service started, listening on 0.0.0.0:9696

sushma-korati gravatar imagesushma-korati ( 2014-09-11 03:01:39 -0500 )edit

or you can also try by running the same command manully to check if you get any more info. cmd:

$ /usr/bin/python /usr/bin/neutron-server --config-file /etc/neutron/neutron.conf --log-file /var/log/neutron/server.log --config-file /etc/neutron/plugins/ml2/ml2_conf.ini

sushma-korati gravatar imagesushma-korati ( 2014-09-11 03:02:23 -0500 )edit

you can use "netstat -ln | grep 9696' to check if a process is listening on that port, and which ip address it's bound to

Remko Duppen gravatar imageRemko Duppen ( 2014-09-13 16:06:17 -0500 )edit