Ask Your Question
1

Swift Stat giving double port error

asked 2014-09-02 20:37:17 -0600

iVaibhav gravatar image

Hi All , I am getting this error below

Account HEAD failed: http://controller:8080:8080/v1/AUTH_c84481ebd46b48509f102a76540ce965 503 Internal Server Error

I am getting this error when trying to run swift stat after configuring object Storage Please guide where to start looking at , the strange part is 8080:8080 in the error above dont know where its coming from

I am following the guide from openstack website and using lab environment I Created in VMWare.

Please Assist

I dont know why my post is being detected as Spam

edit retag flag offensive close merge delete

Comments

Please assist me i am also getting the same error!

hpetwal gravatar imagehpetwal ( 2015-04-24 14:14:39 -0600 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-09-11 01:59:49 -0600

iVaibhav gravatar image

I have figured this out.

While I had copied all *.gz files from the swift directory from my data node to all nodes , I realized that when you make some changes to the data node and rebuild the rings , the *.gz files change and needs to be recopied.

You need to copy the new files again

I did that and the command now works like a charm

Thanks all for assisting me

edit flag offensive delete link more

Comments

Thank you for replying with what actually fixed the problem. I will mark this issue down in my list of "what causes this error"!

SamYaple gravatar imageSamYaple ( 2014-09-11 10:01:42 -0600 )edit
1

answered 2014-09-03 09:36:54 -0600

SamYaple gravatar image

The "double-port" error is a red herring. It is a bug in the error message only. It was fixed in this commit.

Specifically http_host=conn.host, http_port=conn.port changed to http_host=conn.host

Your issue is unrelated to that bug.


Some of the common causes of the 503 error are:

  • incorrect keystone settings in the [filter:authtoken] section of your proxy-server.conf
  • incorrect ring files
  • Incorrect permissions on the folders and mountpoints (should be owned by swift unless otherwaise specified)

Please check these things. If you cannot find the issue, please post your proxy-server.conf and the output of the following commands run from the /etc/swift directory

swift-ring-builder account.builder
swift-ring-builder container.builder
swift-ring-builder object.builder
edit flag offensive delete link more

Comments

Good point. I glossed over that and figured it could be an issue with the incorrect endpoint being used. Many people end up trying to auth against the swift endpoint instead of keystone.

mpetason gravatar imagempetason ( 2014-09-03 10:05:41 -0600 )edit

Hi Sam and Petason ,

Thanks for answering and quick assistance.
1. I got relaxed to know that the double port thing was a bug.

2.  requested outputs here  
http://pastebin.com/zWgcw3q
 and  for proxy-server.conf here 
http://pastebin.com/AYkB6spK
iVaibhav gravatar imageiVaibhav ( 2014-09-03 16:50:29 -0600 )edit

I have reapplied permissions to swift folder after you mentioned just to be sure , but no effect

iVaibhav gravatar imageiVaibhav ( 2014-09-03 16:54:33 -0600 )edit

Please add the pastebin outputs to your initial post. Also http://pastebin.com/zWgcw3q shows as being removed.

Is your keystone server named "controller"? Can you resolve "controller" on your proxy server? Also, verify your memcache_servers line. Check if memcache is listening on that IP.

SamYaple gravatar imageSamYaple ( 2014-09-03 17:00:25 -0600 )edit

Strange... I am posting again

2.  requested outputs here  
http://pastebin.com/zWgcw3qY
 and  for proxy-server.conf here 
http://pastebin.com/AYkB6spK

Yes, my keystone server name is controller and its also configured as my proxy server and memcached server

iVaibhav gravatar imageiVaibhav ( 2014-09-03 18:10:19 -0600 )edit
1

answered 2014-09-03 09:13:05 -0600

mpetason gravatar image

If you setup Swift with Keystone Authentication then you'll need to use the keystone endpoint for the os-auth-url. To find out the keystone endpoint source your openrc file then:

keystone endpoint-list

Look for the endpoint with 35357. Then run swift stat again with this information:

swift --os-auth-url=http://{keystone-IP}:35357/v2.0  stat

See if that returns the results you were looking for. You can also specify the Tenant if you want to differentiate from the Admin tenant.

http://docs.openstack.org/user-guide/...

edit flag offensive delete link more

Comments

1

Hi mpetason,

Thanks for your reply

Here is my output for 35357

vaibhav@controller:~$ swift --os-auth-url=http://controller:35357/v2.0  stat
Account HEAD failed: http://controller:8080:8080/v1/AUTH_9e1e39654fd140f38c31e6d82f4faa5b 503 Internal Server Error
vaibhav@controller:~
iVaibhav gravatar imageiVaibhav ( 2014-09-03 16:53:40 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-02 20:37:17 -0600

Seen: 1,095 times

Last updated: Sep 11 '14