Ask Your Question
0

Heat create failed, Bad network format: missing 'uuid' (HTTP 400)

asked 2014-09-02 06:15:43 -0500

I am using following template to create a Heat Stack.

heat_template_version: 2013-05-23

    description: Hot Template to deploy a single server

    parameters:
      ImageID:
        type: string
        description: Image ID
      NetID:
        type: string
        description: External Network ID

    resources:
      server_0:
        type: OS::Nova::Server
        properties:
          name: "server0"
          image: { get_param: ImageID }
          flavor: "m1.small"
          networks:
          - network: { get_param: NetID }

    outputs:
      server0_ip:
        description: IP of the server
        value: { get_attr: [ server_0, first_address ] }

When I create stack. It shows create failed status. BadRequest: Bad network format: missing 'uuid' (HTTP 400) (Request-ID: req-c8360423-e597-495e-9b36-0158177ccd1a). Below is the snapshot of stack resources. image description

P.S : I checked and double checked the Network ID and Image ID but error remains. heat logs shows same error heat.engine.resource BadRequest: Bad network format: missing 'uuid' (HTTP 400)

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-09-03 08:05:18 -0500

updated 2014-10-16 00:32:04 -0500

The problem was with

 networks:
          - network: { get_param: NetID }

I replaced

- network: { get_param: NetID }

with

- uuid: { get_param: NetID }

and stack created successfully. According to documentation use of uuid is depreciated and network should be used but In my case -uuid work.

P.S I have Openstack havana installed on Ubuntu 12.04.

edit flag offensive delete link more

Comments

1

Ah, yes uuid is required for havana heat:

https://github.com/openstack/heat/blo...

The network syntax was added to the networks schema in the Icehouse heat release, so won't work with Havana Heat.

shardy gravatar imageshardy ( 2014-09-04 06:50:23 -0500 )edit
  1. On controller server, exec:#source demo-openrc.sh
    1. exec:#echo $NET_ID
    2. this command will print same as 3f4bfc72-6a59-4b7f-9b13-f54586b97151
    3. if that is none, then check the demo-net's netid. or create the network for user demo. then try again.
jackieChen gravatar imagejackieChen ( 2015-03-11 04:12:21 -0500 )edit

I am using Icehouse on Ubuntu 12.04. I am using network instead of uuid but still I am getting exactly the same error.

fhussain gravatar imagefhussain ( 2015-04-30 05:53:49 -0500 )edit
2

answered 2014-09-03 03:19:52 -0500

shardy gravatar image

I believe you may need to create a port with the network ID, and pass that to the server:

https://github.com/openstack/heat-tem...

edit flag offensive delete link more

Comments

port creation is optional. Port will automatically be created when VM will provision.

Khayam gravatar imageKhayam ( 2014-09-04 00:34:10 -0500 )edit
0

answered 2015-03-11 04:20:26 -0500

1.On controller server, exec:#source demo-openrc.sh 2.exec:#echo $NET_ID 3.this command will print same as 3f4bfc72-6a59-4b7f-9b13-f54586b97151 4.if that is none, then check the demo-net's netid. or create the network for user demo. then try again.

edit flag offensive delete link more

Comments

centos 7 and juno and use the network not uuid in the template file.

jackieChen gravatar imagejackieChen ( 2015-03-11 04:21:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-02 06:15:43 -0500

Seen: 3,689 times

Last updated: Oct 16 '14