Ask Your Question
1

'/opt/stack/pbr' is not installable. File 'setup.py' not found.

asked 2013-08-29 14:00:22 -0500

adubb gravatar image

Installing devstack and keep getting this problem, tried everything i could think of but must be overlooking something.

Relevant install logs: http://pastebin.com/0iq6pySs

pip seems to be installed as well.

any help appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-08-30 03:34:04 -0500

unmesh-gurjar gravatar image

I guess the issues are because devstack did not clone pbr! I would suggest you delete existing /opt/stack/pbr directory and manually clone it (from: https://github.com/openstack-dev/pbr.git ). You can then checkout the required version (say 0.5.20) of pbr by executing 'git checkout 0.5.20' from /opt/stack/pbr directory. Then run ( unstack.sh if you haven't already and) run the stack.sh script.

edit flag offensive delete link more

Comments

Thank! I must have been tired yesterday. cloned the git file and it put it to /home/stack/pbr instead of in opt, so I changed the command and ran it, now ./stack.sh is working properly

adubb gravatar imageadubb ( 2013-08-30 06:11:02 -0500 )edit

@unmesh-gurjar: I tried but it still gave me error, I completely removed devstack and successfully installed it now.

Deepak gravatar imageDeepak ( 2013-08-30 07:02:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-29 14:00:22 -0500

Seen: 1,544 times

Last updated: Aug 30 '13