Ask Your Question
0

not able to ssh into vm

asked 2014-09-01 22:43:13 -0600

amitabh sinha gravatar image

ssh -i key.pem ubuntu@192.168.1.105 ssh: connect to host 192.168.1.105 port 22: No route to host each and every node is pinging to eacth other both on ntwk 10.10.10.0 as well as 192.168.1.0

edit retag flag offensive close merge delete

Comments

root@controller:~# nova --no-cache secgroup-add-rule default tcp 22 22 0.0.0.0/0 ERROR: This rule already exists in group 2 (HTTP 400) (Request-ID: req-11a174a7-6ac4-43d3-a289-b0298723abd0) root@controller:~# nova --no-cache secgroup-add-rule default tcp 22 22 0.0.0.0/0 ERROR: This rule already exis

amitabh sinha gravatar imageamitabh sinha ( 2014-09-01 23:28:48 -0600 )edit

i have already added security group rules

amitabh sinha gravatar imageamitabh sinha ( 2014-09-01 23:29:13 -0600 )edit

Check your OVS, IP tables. Also do you have SSH server running in your Ubuntu VM?

SGPJ gravatar imageSGPJ ( 2014-09-01 23:44:19 -0600 )edit

i am not able to login in ubuntu vm from console also it is asking username and password?so i dont know whether ssh server is running on ubuntu vm or not but by default ssh server is always running right.! ...what to check in ovs please elaborate! thanks for your nice and fast response

amitabh sinha gravatar imageamitabh sinha ( 2014-09-02 01:29:50 -0600 )edit

I think ubuntu cloud images run ssh server by default. It is not the problem here. No route to host says that the ip is not reachable (whatever port closed or not). 192.168.1 is your external network? For ssh login, by default, password authentication is disabled, so you can only login with your key

T u l gravatar imageT u l ( 2014-09-02 03:02:21 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-09-01 23:00:25 -0600

SGPJ gravatar image

updated 2014-09-02 01:46:43 -0600

First check your default security group rules, add SSH rule if not added.

For quick test you have proper networking setup, launch a CirrOS VM then try to ssh into it and then inject key into new CirrOS VM and test. If it works fine then it is below issue: https://ask.openstack.org/en/question...

edit flag offensive delete link more

Comments

I have added the tcp and icmp rules to it...i am able to do ssh in cirros but i am not able to do it in ubuntu !

amitabh sinha gravatar imageamitabh sinha ( 2014-10-31 12:27:41 -0600 )edit
0

answered 2015-08-12 04:17:42 -0600

sankalp82 gravatar image

I have same problem with Centos VM But I change MTU !!! I have change MTU from 1500 --> 1700 !! Now its work !!!

edit flag offensive delete link more

Comments

thanks for posting answer

SGPJ gravatar imageSGPJ ( 2015-08-13 04:34:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-01 22:43:13 -0600

Seen: 2,754 times

Last updated: Sep 02 '14