icehouse heat wanting to go through proxy

asked 2014-09-01 22:31:12 -0600

rwideman gravatar image

updated 2014-09-02 16:12:10 -0600

mpetason gravatar image

I have a secluded network where I have Openstack Icehouse installed on Ubuntu. To get to the internet I have a proxy setup. So for Icehouse Heat it doesn’t need to contact anything outside of my local Controller as Heat is on the controller, not outside of this server much less on another network needing to go through a proxy.
I am getting the following after configuring Heat on my Controller:

rowidema@iac-opst-controller:~/Downloads$ heat stack-list
ERROR: Authentication failed. Please try again with option --include-password or export HEAT_INCLUDE_PASSWORD=1
Authentication required

I do an “export HEAT_INCLUDE_PASSWORD=1” and then get the following:

rowidema@iac-opst-controller:~/Downloads$ heat stack-list
ERROR: Authentication required

I don’t know why it is trying to go outside my 192.168.x.x network to get to localhost or even the IP of eth0.
Thoughts?

Thanks Robert

EDIT 1:

Hosts:

rowidema@iac-opst-controller:~$ cat /etc/hosts
127.0.0.1       localhost
192.168.1.26    IAC-OPST-Controller.giatac.local IAC-OPST-Controller

Environment:

rowidema@iac-opst-controller:~$ cat /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
http_proxy="http://x.x.x.2:3128/"
https_proxy="https://x.x.x.2:3128/"
ftp_proxy="ftp://x.x.x.2:3128/"
socks_proxy="socks://x.x.x.2:3128/"
no_proxy="localhost,127.0.0.1,x.x.*,192.168.*"

I get the following now:

rowidema@iac-opst-controller:~$ source admin-openrc.sh
rowidema@iac-opst-controller:~$ heat --debug list
DEBUG (session:234) REQ: curl -i -X POST http://192.168.1.26:35357/v2.0/tokens -H "Content-Type: application/json" -H "User-Agent: python-keystoneclient" -d '{"auth": {"tenantName": "admin", "passwordCredentials": {"username": "admin", "password": "mypassword"}}}'
INFO (connectionpool:258) Starting new HTTP connection (1): x.x.x.2
DEBUG (connectionpool:375) Setting read timeout to None
DEBUG (connectionpool:415) "POST http://192.168.1.26:35357/v2.0/tokens HTTP/1.1" 500 143
DEBUG (session:274) RESP: [500] CaseInsensitiveDict({'content-length': '143', 'via': '1.1 proxyserver (squid/3.3.8)', 'x-cache': 'MISS from proxyserver', 'x-cache-lookup': 'MISS from proxyserver:3128', 'vary': 'X-Auth-Token', 'connection': 'keep-alive', 'date': 'Tue, 02 Sep 2014 21:01:48 GMT', 'content-type': 'application/json', 'x-distribution': 'Ubuntu'})
RESP BODY: {"error": {"message": "An unexpected error prevented the server from fulfilling your request.", "code": 500, "title": "Internal Server Error"}}

DEBUG (session:250) Request returned failure status: 500
Traceback (most recent call last):
  File "/usr/bin/heat", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/dist-packages/heatclient/shell.py", line 429, in main
    HeatShell().main(args)
  File "/usr/lib/python2.7/dist-packages/heatclient/shell.py", line 361, in main
    _ksclient = self._get_ksclient(**kwargs)
  File "/usr/lib/python2.7/dist-packages/heatclient/shell.py", line 260, in _get_ksclient
    return ksclient.Client(**kc_args)
  File "/usr/lib/python2.7/dist-packages/keystoneclient/v2_0/client.py", line 144, in __init__
    self.authenticate()
  File "/usr/lib/python2.7/dist-packages/keystoneclient/utils.py", line 318, in inner
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/keystoneclient/httpclient.py", line 392, in authenticate
    resp = self.get_raw_token_from_identity_service(**kwargs)
  File "/usr/lib ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2014-09-02 07:15:17 -0600

Remko Duppen gravatar image

do you have, besides a 'http_proxy', 'https_proxy' and 'ftp_proxy' a 'no_proxy' entry in /etc/environment or your shell profile ?

edit flag offensive delete link more

Comments

I added the following line to /etc/environment and it isnt working. no_proxy="localhost,127.0.0.1,172.18.172.,192.168."

rwideman gravatar imagerwideman ( 2014-09-02 14:53:59 -0600 )edit

I'm pretty sure you can't specify networks by ip addr in 'no_proxy', what if you try the complete ip address ?

Remko Duppen gravatar imageRemko Duppen ( 2014-09-03 03:07:50 -0600 )edit
0

answered 2014-09-02 07:29:06 -0600

sushma-korati gravatar image

Hi,

Even I faced a similer issue, due to below reasons:

  1. Need to point to localhost in /etc/hosts file.

$cat /etc/hosts

127.0.0.1 localhost

CONTROLLER_IP CONTROLLER_NAME

  1. auth_uri in heat.conf is not proper.

File: /etc/heat/heat.conf

auth_uri=http://<your hostname="">:5000/v2.0

-HTH

edit flag offensive delete link more

Comments

I have that line along with the IP specifying the hostname to the local system and not working.

rwideman gravatar imagerwideman ( 2014-09-02 14:54:58 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-01 22:31:12 -0600

Seen: 2,042 times

Last updated: Sep 02 '14