Ask Your Question
0

Error communicating with http://controller:8777 [Errno 111] Connection refused

asked 2014-08-31 08:49:11 -0500

speaktoabu gravatar image

updated 2015-09-23 07:51:44 -0500

I've installed the ceilometer in fedora 20. As per the the document mentioned in the openstack site. But while running the following command, am getting connection refused.

[root@controller ~]# ceilometer meter-list
Error communicating with http://controller:8777 [Errno 111] Connection refused

Trobleshooting:

  1. Disabled selinux and iptables..
  2. uncommented the port 8777 in the celometer.conf file..
  3. verified with netstat command the 8777 port was not listening.

Please advise.

Thanks, -Syed.

edit retag flag offensive close merge delete

Comments

Port 8777 should be opened via /etc/sysconfig/iptables.
Service iptables should be up and running
$ netstat -lntp | grep 8777 should point some process , which PID is required

dbaxps gravatar imagedbaxps ( 2014-08-31 11:15:46 -0500 )edit

Thanks for quick response. I've added the the folowing rule in /etc/sysconfig/iptables and iptables up and running. -A INPUT -p tcp -m tcp --dport 8777 -j ACCEPT and netstat -lntp | grep 8777 doesn't show anything.

speaktoabu gravatar imagespeaktoabu ( 2014-08-31 15:23:20 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
1

answered 2014-09-02 11:04:36 -0500

speaktoabu gravatar image

Fixed the issue.. 1. Mongodb was in failed state, Stopped and started the service again. 2. Changed the ceilometer password in mongodb using the following syntax db.changeUserPassword("ceilometer", "xxxxx") and executed ceilometer meter-list.

edit flag offensive delete link more
1

answered 2014-09-01 02:03:31 -0500

fetahi gravatar image

If the ceilometer-api process is not listening on the port 8777, then you will have to look at the log file for ceilometer-api and see if there is any indication as to what may have caused the problem. You may need to enable debug logging to get more info.

edit flag offensive delete link more

Comments

I've enabled the debug log.. Could find the following . INFO ceilometer.storage.pymongo_base [-] Connecting to mongodb on [('controller', 27017)]. INFO ceilometer.storage.pymongo_base [-] Connecting to mongodb on [('controller', 27017)]

speaktoabu gravatar imagespeaktoabu ( 2014-09-02 09:34:34 -0500 )edit
0

answered 2015-09-23 07:16:51 -0500

I have similar issue with Ice-house and my operating system is ubuntu 14.04 where i can't locate the iptables file i.e. /etc/sysconfig is not exist bydefault. Can you please help to elaborate more on resolution how can i proceed as you have already fixed your issue.

root@controller:~# ceilometer meter-list

Error communicating with http://controller:8777 [Errno 111] Connection refused

Thanks in advance

edit flag offensive delete link more
0

answered 2016-12-14 22:09:25 -0500

I had the same issue. Here is a couple of things to check:

1- Double Check the ceilometer configuration: /etc/ceilometer/ceilometer.conf

[keystone_authtoken] auth_host = controller auth_port = 35357
auth_protocol = http auth_uri = http://controller:5000
admin_tenant_name = service
admin_user = ceilometer
admin_password = CEILOMETER_PASS

[service_credentials]
os_auth_url = http://controller:5000/v2.0
os_username = ceilometer
os_tenant_name = service
os_password = CEILOMETER_PASS

2- Use the logs to investigate the errors:

  • /var/log/keystone/keystone-all.log
  • /var/log/ceilometer/ceilometer-api.log

3- Check mongodb password, reset if needed

4- Check Ceilometer services:

export CEILO_SVCS='agent-central agent-notification ceilometer-api ceilometer-collector alarm-evaluator alarm-notifier' for svc in $CEILO_SVCS ; do sudo service ceilometer-$svc restart ; done

5- Check if the service and the endpoints (admin, internal and public) are correctly configured

6- [This solved my issue] Check the user ceilometer password, if needed delete and recreate the user and assign the appropriate role and roject, this solved my issue.

(Careful!! It was in a lab environment during first deployment, I guess it would be eventual consequences for your alarms created with the old user!! )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-31 08:49:11 -0500

Seen: 2,035 times

Last updated: Dec 14 '16