Ask Your Question
0

starting rcopenstack-swift-proxy errno 1?

asked 2013-08-29 09:48:16 -0500

blazesurfer gravatar image

updated 2013-08-29 09:51:13 -0500

Jobin gravatar image
Starting swift-proxy-serverTraceback (most recent call last):
  File "/usr/bin/swift-proxy-server", line 22, in <module>
    run_wsgi(conf_file, 'proxy-server', default_port=8080, **options)
  File "/usr/lib64/python2.6/site-packages/swift/common/wsgi.py", line 127, in run_wsgi
    drop_privileges(conf.get('user', 'swift'))
  File "/usr/lib64/python2.6/site-packages/swift/common/utils.py", line 855, in drop_privileges
    os.setgid(user[3])
OSError: [Errno 1] Operation not permitted
startproc:  exit status of parent of /usr/bin/swift-proxy-server: 1

Has any one else experienced this? is this some thing silly i have missed.

running on sles 11 sp3 installed from repo. configured by hand for swift.

edit retag flag offensive close merge delete

Comments

What is the command you have executed?

Jobin gravatar imageJobin ( 2013-08-29 09:51:54 -0500 )edit

just trying to start the service.. or daemon. using rcopenstack-swift-proxy start Im expecting it to be rights based i think, though good chance im wrong. similar happens with the other swift modules as well.

blazesurfer gravatar imageblazesurfer ( 2013-08-29 09:53:14 -0500 )edit

If i start the service using swift-init proxy start.. it starts fine i can even then run rcopenstack-swift-proxy status and it reports ok

blazesurfer gravatar imageblazesurfer ( 2013-08-29 10:08:11 -0500 )edit

@blazesurfer: Can you please add the commands and their respecitive outputs to the question?

Jobin gravatar imageJobin ( 2013-08-29 10:30:40 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-08-29 10:36:51 -0500

blazesurfer gravatar image

Hi Jobin

thank you for your interest.

I have found the issue..

so the command was starting /etc/init.d/openstack-swift-proxy or any of the other swift components.

after inspecting the /etc/init.d/openstack-swift-proxy file I found that the user the daemon was trying to run as, isnt the user i have set every thing up as.. so that was my problem..

so have updated this line in /etc/init.d/openstack-swift-proxy to be the user i have setup. (i will need to go back and set them to be all the default that it is installed with as a future proof task but for now this is getting me working.. one issue off the list tonight)

CHUSER="-u swift"

Regards

Scott

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-29 09:48:16 -0500

Seen: 241 times

Last updated: Aug 29 '13