Ask Your Question
0

The external gateway on router in openstack grizzly all in one on virtual box is down what i should do ?

asked 2013-08-29 06:02:02 -0500

bishoy gravatar image

updated 2014-01-22 15:12:44 -0500

Evgeny gravatar image

I have installed Openstack grizzly all in one node on a virtual box and every thing seemed to be fine until i created external network and add gateway from the router to it but the it is down what make the instances can't reach internet and can't load to get the metadata and freezes on loading? what i should do any tips ??? does the problem related to that i deploying every thing on a virtual box but iam making all networks bridged ??

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2013-08-29 13:01:05 -0500

Hrushi gravatar image

That is normal behavior. It is expected to be fixed in Havana. Here are the tips: 1. Ensure the VM instance got an IP address..look at console.log

  1. Ext NIC settings – no ip on the logical and might like to assign ip on br-ex. Typically, looks like: auto eth2 iface eth2 inet manual up ifconfig $IFACE 0.0.0.0 up up ip link set $IFACE promisc on down ip link set $IFACE promisc off down ifconfig $IFACE down

auto br-ex iface br-ex inet static address 10.1.56.12 netmask 255.255.255.0

  1. All bridges on all the nodes (br-ex, br-int, br-tun) needs to up and running (must add in interfaces to ensure it is UP on reboot)

  2. If using vmware as virtualized environment, promiscuous setting to Accept on the vSwitch. Or, must be set on hardware switch

edit flag offensive delete link more

Comments

Hrushi, I also encountered this issue: Cannot access external network from instance. I built three nodes on VMWare virtual machines, so I change the promiscuous to Accept on the vSwitch, the issue was fixed. Thanks! One more question: Do you mean this is an issue of OpenStack? And this issue will be fixed in next release, after it's fixed, will not need change the promiscuous setting to Accept on vSwitch, right?

Leo gravatar imageLeo ( 2013-09-29 04:52:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-29 06:02:02 -0500

Seen: 757 times

Last updated: Aug 29 '13