Ask Your Question
2

Horizon Errors when using OpenStack (+OpenDayLight)

asked 2014-08-28 10:58:39 -0500

skyw@lker gravatar image

updated 2014-08-30 13:18:15 -0500

Hi all,

I am trying to run OpenStack with OpenDayLight. There are a controller node and a compute node. I have used the instructions and the virtual machine(s) from http://networkstatic.net/updated-devs...

I am able to use Dashoard but I get the following errors:

  • In Admin -> System Panel -> Overview

    Error: Unable to retrieve volume limit information.

  • In Admin -> SystemPanel -> System Info

    Error: Unable to get quota info.

  • In Admin -> System Panel -> Volumes

    Error: Unable to retrieve volume list.

    Error: Unable to retrieve volume types

These errors appear also in different places in the Horizon menu.

Have you ever faced them? What could be the causes? How could I do?

I specify that I am new to OpenStack and ODL.

Thank you.

PS:

When I try to create a new instance I get:

Error: Unable to retrieve list of volume snapshots.

Error: Unable to retrieve list of volumes.

Error: There was an error submitting the form. Please try again.

Error: Unable to retrieve list of volume snapshots.

Error: Unable to retrieve list of volumes.

Update1:(see also UPDATE2 at the bottom) I suspect the issues that I presented above could be related to the following error(seen in stack.sh.log):

2014-08-29 09:05:26.486 | + sudo mysqladmin -u root password mysql
2014-08-29 09:05:26.498 | mysqladmin: connect to server at 'localhost' failed
2014-08-29 09:05:26.505 | error: 'Access denied for user 'root'@'localhost' (using password: NO)'
2014-08-29 09:05:26.519 | + true
2014-08-29 09:05:26.526 | + sudo mysql -uroot -pmysql -h127.0.0.1 -e 'GRANT ALL PRIVILEGES ON *.* TO '\''root'\''@'\''%'\'' identified by '\''mysql'\'';'
2014-08-29 09:05:26.533 | + sudo bash -c 'source /home/odl/devstack/functions &&         iniset /etc/my.cnf mysqld bind-address 0.0.0.0 &&         iniset /etc/my.cnf mysqld default-storage-engine InnoDB'

The mysql root password is 'mysql'. Even-though the virtual machine comes with exactly the same password, I had to reset it using the commands described in http://potofjoy.com/flavioBlog/work/h... due to ERROR 1045 (28000): Access denied for user 'root'@'fedora-odl-1' (using password: YES) that I solved using mysql --user=root --password=mysql mysql [........]

https://www.dropbox.com/s/inu6c4v182t... contains all the messages that I got during the stack process, including the section above.

In the following I would like to write the configuration of both control(fedora-odl-1) and compute(fedora-odl-2) nodes:

[odl@fedora-odl-1 opendaylight]$ ifconfig eth2
    inet 192.168.57.101  netmask 255.255.255.0  broadcast 192.168.57.255
[odl@fedora-odl-2 devstack]$ ifconfig eth2
    inet 192.168.57.102  netmask 255.255.255.0  broadcast 192.168.57.255

This is the local.conf in the controller node:

[[local|localrc]]
LOGFILE=stack.sh.log
#SCREEN_LOGDIR=/opt/stack/data/log
#LOG_COLOR=False
OFFLINE=True
#RECLONE=yes

# Only uncomment the below two lines if you are running on Fedora
disable_service rabbit
enable_service qpid
#disable_service n-cpu
enable_service n-cond
disable_service n-net
enable_service q-svc
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service quantum
enable_service tempest

Q_HOST=$SERVICE_HOST
HOST_IP=192.168.57 ...
(more)
edit retag flag offensive close merge delete

Comments

Yes, it is probably related to mysql problem (nothing to do with opendaylight) To which ip your hostname is resoved? (e.g. when you ping fedora-odl-1 ?) maybe try to change your /etc/hosts such that your hostname resolves to 192.168.57.101, 192.168.57.101 fedora-odl-1 ?

T u l gravatar imageT u l ( 2014-08-30 09:48:03 -0500 )edit

initially the hostname was resolved to 127.0.0.1. After swapping the lines in hosts it resolves to 192.168.57.101. Unfortunately, all errors are still there.

skyw@lker gravatar imageskyw@lker ( 2014-08-30 13:00:13 -0500 )edit

just to be sure, what is the error (in log files)?

can you also add a record to mysql.user for host 'fedora-odl-1' (regardless the wildcard one %) ?

T u l gravatar imageT u l ( 2014-08-30 15:38:36 -0500 )edit

try using maria db in fedora instead of sql.

SGPJ gravatar imageSGPJ ( 2014-08-31 03:50:51 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-08-29 08:03:14 -0500

SGPJ gravatar image
edit flag offensive delete link more
0

answered 2015-09-02 08:57:57 -0500

I was having this error in OpenStack Juno, Ubuntu 14.04. Fixed by reinstalling some missing packages on controller node inside http://docs.openstack.org/juno/install-guide/install/apt/content/cinder-install-controller-node.html (the cinder section) of Openstack Installation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-28 10:58:39 -0500

Seen: 6,127 times

Last updated: Sep 02 '15