Ask Your Question
1

CINDER ERROR: No suitable rootwrap found

asked 2014-08-28 05:42:11 -0600

updated 2014-08-29 01:39:14 -0600

I have been trying to install devstack with opencontrail and following this post. The issue i ran into is when i run ./stack.sh it stuck at a point when configuring Cinder. It sops by giving this error ERROR: No suitable rootwrap found I have tried various work around, like installing different packages but those dint work out. Any body here know what may be wrong in the scenario. I am using Ubuntu 12.04

edit retag flag offensive close merge delete

Comments

could you paste the complete log using paste.openstack.org ? The main cause could be something else.

prasoontelang gravatar imageprasoontelang ( 2014-08-29 04:30:19 -0600 )edit

i have pasted the log you can see it here

Syed Awais Ali gravatar imageSyed Awais Ali ( 2014-08-29 04:39:20 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-08-29 06:08:13 -0600

Thanks for the log!

Following lines from 58-62 seems to be the trigger

2014-08-28 20:16:49 Downloading/unpacking oslo.config>=1.4.0.0a3 (from cinder==2014.2.0.dev213.g9bddf33)
2014-08-28 20:16:49   Could not find a version that satisfies the requirement oslo.config>=1.4.0.0a3 (from cinder==2014.2.0.dev213.g9bddf33) (from versions: 1.1.0, 1.1.1, 1.2.0, 1.2.1, 1.3.0)
2014-08-28 20:16:49 Cleaning up...
2014-08-28 20:16:49 No distributions matching the version for oslo.config>=1.4.0.0a3 (from cinder==2014.2.0.dev213.g9bddf33)
2014-08-28 20:16:49 Storing complete log in /home/ubuntu/.pip/pip.log

and then later this is the error:

2014-08-28 20:16:49 ++ echo /usr/local/bin/oslo-rootwrap
2014-08-28 20:16:49 + CINDER_ROOTWRAP=/usr/local/bin/oslo-rootwrap
2014-08-28 20:16:49 + [[ ! -x /usr/local/bin/oslo-rootwrap ]]
2014-08-28 20:16:49 + die 176 'No suitable rootwrap found.'

Does downloading oslo.rootwrap package help?

sudo pip install oslo.rootwrap
edit flag offensive delete link more

Comments

I executed the command you mentioned and the out is

Requirement already up-to-date: oslo.rootwrap in /opt/stack/oslo.rootwrap Requirement already up-to-date: six>=1.7.0 in /usr/local/lib/python2.7/dist-packages (from oslo.rootwrap) Cleaning up...

Syed Awais Ali gravatar imageSyed Awais Ali ( 2014-08-29 06:11:04 -0600 )edit

Does the info in the following links help? Launchpad Devstack & Redhat

prasoontelang gravatar imageprasoontelang ( 2014-08-29 06:24:38 -0600 )edit

yes Prasoontelang, i have gone through these links. but to no avail. Actually i am trying to fidn out a root cause of the issue and then troubleshoot it

Syed Awais Ali gravatar imageSyed Awais Ali ( 2014-08-29 06:27:14 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-28 05:42:11 -0600

Seen: 5,008 times

Last updated: Aug 29 '14