Ask Your Question
0

vnc console failed to connect to server (code: 1006)

asked 2014-08-28 03:43:59 -0500

gopisaba gravatar image

updated 2014-08-28 04:12:44 -0500

dbaxps gravatar image

i have configured 3 node architecture 1 Controller, 1 Compute, and 1 Neutron. Everything looks fine but i couldnt get the vnc console of the instances. i tried all the options after i googled.

Error Message:
Failed to Connect to Server (Code: 1006)

Controller node nova.conf:
[DEFAULT]
rpc_backend = qpid
qpid_hostname = controller.fqdn.com
my_ip = 192.168.1.11
vncserver_listen = 192.168.1.13
vncserver_proxyclient_address = 192.168.1.13
auth_strategy = keystone
network_api_class = nova.network.neutronv2.api.API
neutron_url = http://controller.fqdn.com:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = neutron
neutron_admin_password = password
neutron_admin_auth_url = http://controller.fqdn.com:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
security_group_api = neutron
novncproxy_host=0.0.0.0
novncproxy_port=6080
novncproxy_base_url=http://192.168.1.11:6080/vnc_auto.html

Compute node nova.conf:
[DEFAULT]
auth_strategy = keystone
rpc_backend = qpid
qpid_hostname = controller.fqdn.com
my_ip = 192.168.1.31
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 192.168.1.31
novncproxy_base_url = http://controller.fqdn.com:6080/vnc_auto.html
glance_host = controller.fqdn.com
network_api_class = nova.network.neutronv2.api.API
neutron_url = http://controller.fqdn.com:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = neutron
neutron_admin_password = password
neutron_admin_auth_url = http://controller.fqdn.com:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
security_group_api = neutron



What could be the issue?
edit retag flag offensive close merge delete

Comments

What reports
netstat -lntp| grep 6080
Status of services
openstack-nova-consoleauth.service
openstack-nova-novncproxy.service

dbaxps gravatar imagedbaxps ( 2014-08-28 04:17:56 -0500 )edit

[root@controller Desktop]# netstat -lntp| grep 6080 tcp 0 0 0.0.0.0:6080 0.0.0.0:* LISTEN 2815/python
[root@controller Desktop]# service openstack-nova-consoleauth status openstack-nova-consoleauth (pid 2807) is running... [root@controller

gopisaba gravatar imagegopisaba ( 2014-08-28 04:58:30 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
0

answered 2015-01-28 15:15:13 -0500

francois gravatar image

Even-though I had disabled the firewall between all nodes

after hours of looking around, tcpdump to the rescue

on the controller node

tcpdump -nni eno1 port 5900

replace eno1 with the management interface , try to launch your vnc-console, you should see a single line computenode:5900

13:55:43.880155 IP 10.0.70.70.45261 > 10.0.70.93.5900: Flags [S], seq 1495139310, win 14600, options [mss 1460,sackOK,TS val 12232244 ecr 0,nop,wscale 7], length 0

Go to the computer node and issue iptables -L you may be surprise as I was to see it was running

Again issues iptables -F to drop all tables. Reload your dashboard and launch your vnc-console again

... and smile (if it was the same problem as mine)

edit flag offensive delete link more
0

answered 2016-03-03 11:07:42 -0500

On dashboard Project->Compute->Access&Security can you find "Security group" and enable SSH access to instances

edit flag offensive delete link more
0

answered 2014-12-05 09:10:28 -0500

Mars gravatar image

Experiencing the same issue. Does anyone help to figure it out?

:(

edit flag offensive delete link more
0

answered 2014-12-08 11:06:46 -0500

mpetason gravatar image

You have two different IP addresses configured. Does the controller actually listen on .13? Or did you setup a VIP? If that is the issue then you can change the listen address to .11 and the proxy_client.

my_ip = 192.168.1.11
vncserver_listen = 192.168.1.13
vncserver_proxyclient_address = 192.168.1.13

To

my_ip = 192.168.1.11
vncserver_listen = 192.168.1.11
vncserver_proxyclient_address = 192.168.1.11

Also make sure you can resolve the Controller address locally. You don't want to use the address you have setup, it should be an internal domain if you are using a domain name: controller.fqdn.com

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-28 03:42:39 -0500

Seen: 11,651 times

Last updated: Mar 03 '16