Ask Your Question
0

neutron existing subnet

asked 2014-08-27 13:14:19 -0500

tcway gravatar image

updated 2014-08-27 13:45:17 -0500

mpetason gravatar image

my vlans for the virts have gateways on the cisco router upstream so I do not need to assign a gateway , but I cannot figure out how to create a subnet to attach to a network without assigning a gateway , and when I do assign the cisco gateway as the subnet gateway , my virts work perfectly but then my router starts complaining about duplicate ip addresses , the subnet gateway I assign gets assigned to an interface on the router . any suggestions ?

layout

eth0

eth0 ( access vlan 100 - gateway 10.10.100.1 [trunked vlans 110 - 120 )  
DEVICE=eth0
HWADDR="00:25:B5:01:A0:12"
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
ONBOOT=yes

br-ex

br-ex 10.10.100.20
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=10.10.100.20
PREFIX=24
GATEWAY=10.10.100.1
ONBOOT=yes

eth1

eth1  ( trunked vlans 110-120 ) 
DEVICE=eth1
BOOTPROTO=none
IPV6INIT="no"
NM_CONTROLLED="yes"
ONBOOT=yes
TYPE=OVSPort
UUID="3bed5126-a9b5-4c4b-af0c-24655aaf1469"
OVS_BRIDGE=br-eth1
OVSBOOTPROTO=none
DEVICETYPE=ovs

ovs

84335425-1ceb-4db8-9245-9dce7b6281c2
    Bridge "br-eth1"
        Port "eth1"
            Interface "eth1"
        Port "br-eth1"
            Interface "br-eth1"
                type: internal
        Port "phy-br-eth1"
            Interface "phy-br-eth1"
    Bridge br-int
        fail_mode: secure
        Port "int-br-eth1"
            Interface "int-br-eth1"
        Port br-int
            Interface br-int
                type: internal
    Bridge br-ex
        Port "eth0"
            Interface "eth0"
        Port br-ex
            Interface br-ex
                type: internal
    ovs_version: "1.11.0"

answer_file

CONFIG_NEUTRON_L2_AGENT=openvswitch
CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=vlan
CONFIG_NEUTRON_OVS_VLAN_RANGES=physnet:110:120
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=physnet:br-eth1
CONFIG_NEUTRON_OVS_BRIDGE_IFACES=br-eth1:eth1
CONFIG_NEUTRON_L3_EXT_BRIDGE=br-ex
CONFIG_NEUTRON_L2_PLUGIN=openvswitch
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-08-27 14:46:55 -0500

tcway gravatar image

answering my own question :

so it looks like I just had to use --router:external=True when I created my network , and not create a router and everything appears to be working properly .

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-27 13:14:19 -0500

Seen: 152 times

Last updated: Aug 27 '14