Ask Your Question
1

How can I force the instance to mount a volume as different device?

asked 2014-08-27 08:25:57 -0500

Piotr gravatar image

updated 2014-08-29 18:02:13 -0500

smaffulli gravatar image

Hello I have a quite strange problem with attached volume. I have one volume in cinder, one instance and I'm trying to attach this volume as a drive /dev/vdd to the instance. I'm using the command:

nova volume-attach test123 caa842b2-efee-4d80-a342-d5310cd168a2 /dev/vdd

But the dmesg on instance shows that the volume is attached as vdb. nova volume show shows :

| attachments                    | [{"device": "/dev/vdd", "server_id": "5fe3ca19-07ed-4e0b-9f0f-ed5a57704cde", "volume_id": "caa842b2-efee-4d80-a342-d5310cd168a2", "host_name": null, "id": "caa842b2-efee-4d80-a342-d5310cd168a2"}] |

How can I force the instance to use this volume as vdd not vdb? I can write some udev rules or make a link to this device but IMHO the instance should use the device name provided by nova volume-attach command.

edit retag flag offensive close merge delete

Comments

See if it does the same when you launch the instance with the volume added as /dev/vdd. It may be due to metadata. I know that whenever you hot attach storage it always goes to the next available device. I don't know if you can force KVM to attach it when there isn't vdb vdc already added.

mpetason gravatar imagempetason ( 2014-08-27 12:52:19 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-09-02 08:43:57 -0500

gmi gravatar image

When you attach a volume, KVM ignores the device name you pass because it does its own naming (this behavior is documented here: https://wiki.openstack.org/wiki/Block... )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-27 08:25:57 -0500

Seen: 861 times

Last updated: Sep 02 '14