Ask Your Question
0

neutron security group not working

asked 2014-08-27 08:14:58 -0600

ashu gravatar image

updated 2014-08-27 12:40:34 -0600

mpetason gravatar image

Hi, I'm having below lines in my /etc/nova/nova.conf ..

    firewall_driver=nova.virt.firewall.NoopFirewallDriver
    security_group_api=neutron

and below lines in my ovs plugin file i.e /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini

    firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

But still my neutron security groups are not working and are producing below errors..

    # neutron security-group-list
    404 Not Found
    The resource could not be found.

My all other neutron commands are working fine

Please help regarding this.

Thanks

edit retag flag offensive close merge delete

Comments

What does core_plugin in /etc/neutron/neutron.conf say? Does that plugin have 'security-group' in the list supported_extension_aliases member variable?

prasoontelang gravatar imageprasoontelang ( 2014-08-27 09:41:13 -0600 )edit
  • Hi

    Thanks for the reply.

    The core_plugin in /etc/neutron/neutron.conf is neutron.plugins.openvswitch.ovs_neutron_plugin.OVSNeutronPluginV2

ashu gravatar imageashu ( 2014-08-27 12:27:51 -0600 )edit

Restart the neutron-server and then look for something like " INFO neutron.api.extensions [-] Loaded extension: security-group", do you see that?

prasoontelang gravatar imageprasoontelang ( 2014-08-27 12:56:25 -0600 )edit

Thanks.

I'll test this and let you know this in morning I.S.T.

ashu gravatar imageashu ( 2014-08-27 13:02:25 -0600 )edit

Sounds good. When I say "should be commented out" I mean by default it is commented out, you'll want to remove the comment and verify that it matches the same driver.

mpetason gravatar imagempetason ( 2014-08-27 13:10:58 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-08-27 12:59:45 -0600

mpetason gravatar image

I believe I ran into issues with this before where you also have to specify it in /etc/neutron/neutron.conf. It should be commented out or not have anything included, then you need to verify that it has the same driver as the ovs plugin.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-08-27 08:14:58 -0600

Seen: 750 times

Last updated: Aug 27 '14