Ask Your Question
0

Cinder : Volume creation Issue

asked 2013-08-29 02:00:35 -0500

RHK gravatar image

updated 2013-10-08 23:56:08 -0500

I am Creating a 1 GB test volume.

$ cinder create --display_name test 1 (But its not showing any out put and the command is still running)

I check in another termional cinder list

+--------------------------------------+----------+--------------+------+-------------+----------+-------------+ | ID | Status | Display Name | Size | Volume Type | Bootable | Attached to | +--------------------------------------+----------+--------------+------+-------------+----------+-------------+ | dcd14f1c-8293-4c0b-83ad-29826c1fc9c3 | creating | test | 1 | None | false | | +--------------------------------------+----------+--------------+------+-------------+----------+-------------+

here the status is still creating but as per the document status ha sto be available. Plz any one from this forums let me know why the staus is creating in my output.

Regards, RHK

edit retag flag offensive close merge delete

Comments

1

Check the Cinder service(s) logs for errors. That will help debugging the issue.

unmesh-gurjar gravatar imageunmesh-gurjar ( 2013-08-29 03:04:40 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-10-09 07:31:05 -0500

RomilGupta gravatar image

Can you please let us know where your rabbitmq-server is running , Is it the same machine where you have installed cinder ?

Check whether the respective queues and exchanges for cinder is created or not by using commands below :

For queues : rabbitmqctl list_queues | grep cinder For exchanges : rabbitmqctl list_exchanges | grep cinder

Also verify your Configuration in /etc/cinder/api-paste.ini like the following:

[filter:authtoken]
paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory
service_protocol = http
service_host = <IP>
service_port = 5000
auth_host =  < IP >
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = cinder
admin_password = service_pass

/etc/cinder/cinder.conf to:

[DEFAULT]
rootwrap_config=/etc/cinder/rootwrap.conf
sql_connection = mysql://cinderUser:cinderPass@<IP>/cinder
api_paste_config = /etc/cinder/api-paste.ini
iscsi_helper=ietadm
volume_name_template = volume-%s
volume_group = cinder-volumes
verbose = True
auth_strategy = keystone
#osapi_volume_listen_port=5900
edit flag offensive delete link more
0

answered 2013-08-29 09:57:00 -0500

gans-developer gravatar image

Check the cinder-volume log and trace the error.

edit flag offensive delete link more

Comments

please add request for logs as comments not answers :)

coolsvap gravatar imagecoolsvap ( 2013-08-29 23:20:36 -0500 )edit

Thanks, will take care next time :)

gans-developer gravatar imagegans-developer ( 2013-08-30 02:02:36 -0500 )edit

Yes, i check the log RabbitMQ server is unreachable. How to fix this rabbitMQ unreachable issue.

RHK gravatar imageRHK ( 2013-10-08 23:53:46 -0500 )edit

Is RabbitMQ on same machine or different? If its on different machine check the connectivity.

sngirame gravatar imagesngirame ( 2013-10-09 07:11:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-29 02:00:35 -0500

Seen: 145 times

Last updated: Oct 09 '13