Ask Your Question
0

Icehouse keystone user-list : Authorization

asked 2014-08-26 07:28:55 -0500

julienonline gravatar image

updated 2014-08-26 09:03:04 -0500

Hello guys, I would like to share an issue, I am not able to solve. Julien

First use of keystone : (keystone user-list) WARNING:urllib3.connectionpool:Retrying (0 attempts remain) after connection broken by 'BadStatusLine('',)': http://dvopscontroller:35357/v2.0/tokens Authorization Failed: Unable to establish connection to http://dvopscontroller:35357/v2.0/tokens

Second use (and after) of keystone : Authorization Failed: Not Found (HTTP 404)

I am not able to make run kestone, yesterday i was working fine.

[root@dvopscontroller ~]# service mysqld status
mysqld (pid  1680) is running...
[root@dvopscontroller ~]# service qpid status
qpid: unrecognized service
[root@dvopscontroller ~]# service qpidd status
qpidd (pid  1713) is running...
[root@dvopscontroller ~]# more admin-openrc.sh
export OS_USERNAME=admin
export OS_PASSWORD=ADMIN_PASS
export OS_TENANT_NAME=admin
export OS_AUTH_URL=http://dvopscontroller:35357/v2.0
export https_proxy=http://192.168.70.52:3128
export http_proxy=http://192.168.70.52:3128
[root@dvopscontroller ~]# source admin-openrc.sh

[root@dvopscontroller ~]# keystone user-list
WARNING:urllib3.connectionpool:Retrying (0 attempts remain) after connection broken by 'BadStatusLine('',)': http://dvopscontroller:35357/v2.0/tokens
Authorization Failed: Unable to establish connection to http://dvopscontroller:35357/v2.0/tokens

[root@dvopscontroller ~]# curl http://dvopscontroller:35357/v2.0/tokens
<html>
<head>
<title>Network Error</title>
…
 **[root@dvopscontroller ~]# keystone user-list
Authorization Failed: Not Found (HTTP 404)
[root@dvopscontroller ~]#**
edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2014-08-26 09:05:50 -0500

Most probably you are hitting proxy server. Is it supposed to go via proxy or no_proxy? If no_proxy set, no_proxy=dvopscontroller.

To verify try this

http://dvopscontroller:35357

wget will tell you whether it hits via proxy server

edit flag offensive delete link more
0

answered 2014-08-26 09:24:29 -0500

julienonline gravatar image

Indeed I did use proxy ntlm to access repository on internet from my internal network. [root@dvopscontroller ~]# unset http_proxy [root@dvopscontroller ~]# unset https_proxy

thank you

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-26 07:28:55 -0500

Seen: 489 times

Last updated: Aug 26 '14