Ask Your Question
0

heat standalone mode issues

asked 2014-08-25 14:08:39 -0500

ost gravatar image

updated 2014-08-26 10:59:58 -0500

mpetason gravatar image

Hi, Can I configure heat in standalone mode, so that it can interface with openstack based public cloud to create instances? I followed this link http://docs.openstack.org/developer/h... , but no luck... any supporting documents or howto will be helpful?

After following above link I am getting following error:

ERROR: 401 Unauthorized

This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.

Authentication required
edit retag flag offensive close merge delete

Comments

1

You may want to see if there is more information in the logs. If it's talking about Authorization then it is probably looking for a Keystone endpoint or something along those lines.

mpetason gravatar imagempetason ( 2014-08-26 11:00:35 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-09-24 17:01:25 -0500

Steve Baker gravatar image

Make sure your locally sourced credentials have the following:

  • export OS_NO_CLIENT_AUTH=True
  • export HEAT_URL=(Your heat endpoint including your tenant ID)

The heat-api log may provide clues to the issue, which may be incorrect auth settings in /etc/heat/heat.conf

edit flag offensive delete link more
0

answered 2015-09-24 17:34:16 -0500

asalkeld gravatar image

Hi

I am use standalone everyday here are my settings:

$ env | grep OS
OS_NO_CLIENT_AUTH=True
OS_REGION_NAME=RegionOne
OS_PASSWORD=***-not-this-***
OS_AUTH_URL=http://10.0.0.39:5000/v2.0
OS_USERNAME=admin
OS_TENANT_NAME=demo
OS_VOLUME_API_VERSION=2
$ env | grep HEAT
HEAT_URL=http://10.0.0.75:8004/v1/e80f6867c5b74ad49a75964fff4f4686

Make sure to get the tenant_id correct for the tenant name that you are using. So for my tenant of "demo" it's tenant_id is "e80f6867c5b74ad49a75964fff4f4686" (which is part of the HEAT_URL).

Also you will have to figure out the public cloud's region that you want to work with.

So here is a debug session:

 heat --debug stack-list
 DEBUG (http) curl -g -i -X GET -H 'X-Auth-User: admin' -H 'User-Agent: python-heatclient' -H 'X-Auth-Key: ***-not-this-***' -H 'Accept: application/json' -H 'Content-Type: application/json' -H 'X-Auth-Url: http://10.0.0.39:5000/v2.0' http://10.0.0.75:8004/v1/e80f6867c5b74ad49a75964fff4f4686/stacks?
 INFO (connectionpool) Starting new HTTP connection (1): 10.0.0.75
 DEBUG (connectionpool) "GET /v1/e80f6867c5b74ad49a75964fff4f4686/stacks HTTP/1.1" 200 14
 DEBUG (http) 
 HTTP/1.1 200 OK
 date: Thu, 24 Sep 2015 22:19:07 GMT
 connection: keep-alive
 content-type: application/json; charset=UTF-8
 content-length: 14
 x-openstack-request-id: req-ca132cbc-24ae-4e08-afd2-ff3191318901

 {"stacks": []}

 +----+------------+--------------+---------------+--------------+
 | id | stack_name | stack_status | creation_time | updated_time |
 +----+------------+--------------+---------------+--------------+
 +----+------------+--------------+---------------+--------------+

One last thing is, what public cloud are you trying to talk to?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-25 14:08:39 -0500

Seen: 211 times

Last updated: Sep 24 '15