Ask Your Question
0

Problem with neutron networking on single server

asked 2014-08-25 00:02:19 -0500

Piotr gravatar image

Hi I have one dell server on which I have a full open-stack installation (keystone, cinder, glance, swift, neutron and others) I have one physical interface on this server (eth0 IP 10.50.40.30, netmask 24 bits, gateway .254, no vlans) I can create router, add private network (local network for instances) but I can't force neutron to use the eth0 on physical server as a gateway for the virtual machines. The vms are spawned (2-3 instances), they can see each other (ssh, ping works like a charm) but I have no access to the outside network from these vms. How should I configure the neutron router to use my external network and access the internet from the vms and access vms from my network? I tried method described in OpenStack Cloud Admin Guide but it's not working. I'm using Havana with OVS plug-in.

Thank you for your help

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-08-25 01:06:25 -0500

SGPJ gravatar image

Please follow this tutorial which talks about installing Opensyack on single node with every bit of detail. Link: http://blog.flux7.com/blogs/openstack...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-25 00:02:19 -0500

Seen: 101 times

Last updated: Aug 25 '14