Ask Your Question
1

Nova compute stays up (state :-) )even after host shutdown [closed]

asked 2014-08-22 10:04:54 -0500

Sergei Hanus gravatar image

I work with Havana installation, one control host plus two nova-compute (libvirt with kvm). I'm trying to set up guest VM high availability solution - monitor host going down and do host-evacuate via API.

My problem is: even when I shutdown compute host, 'nova-manage service list' shows that this host state is up (not XXX, but smiley face). And, when in this state, host-evacuate command is not willing to be executed - it expects host to be in down state.

Maybe, somebody could give an advice - how to troubleshoot this situation and where to look?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SamYaple
close date 2014-08-25 14:22:43.452328

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-08-22 11:15:01 -0500

SamYaple gravatar image

I have seen similiar issues when the time was not syncronized as it should be

edit flag offensive delete link more

Comments

Thanks for advice. Really, I had time shift right after installation of all components. Later I noticed it and synced everything, but even after rebooting situation didn't change. If you have such guess - maybe, there's some way to "synchronize" all components agein inside openstack?

Sergei Hanus gravatar imageSergei Hanus ( 2014-08-25 03:13:59 -0500 )edit

You can mark the node down administratively, that may fix this issue and have evac work.

If the last checkin from that node was in the future, maybe thats why it stays up? But you would think it would use the controller nodes timestamp...

SamYaple gravatar imageSamYaple ( 2014-08-25 09:53:06 -0500 )edit
0

answered 2014-08-25 10:46:46 -0500

Sergei Hanus gravatar image

Your guess led me to the check-in timer. I took a look at nova.conf - and found out, that by some reason service_down_time parameter was set to 100000. I think, because of that controller needed to wait a lot of time before realizing that compute is dead. I changed it to 30 - it's working fine now.

edit flag offensive delete link more

Comments

Glad to hear it! It is always something wierd like that. I will go ahead and close your question.

SamYaple gravatar imageSamYaple ( 2014-08-25 14:22:37 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-22 10:04:54 -0500

Seen: 345 times

Last updated: Aug 22 '14