ERROR nova.virt.libvirt.driver [-] Nova requires libvirt version 0.9.6 or greater

asked 2014-08-21 08:38:39 -0600

rajcoumar gravatar image

Actually I am working on Openstack Havana Package. I installed Keystone, Cinder, Horizon, Glance, Nova (api,scheduler,conductor,consoleauth,novncproxy,cert) in one Virtual machine. I installed nova compute on another kvm machine.

When I start the nova-compute serivce on compute node, I am getting errors

    ERROR nova.virt.libvirt.driver [-] Nova requires libvirt version 0.9.6 or greater
edit retag flag offensive close merge delete

Comments

Which OS is running on compute node where VM is starting ?

dbaxps gravatar imagedbaxps ( 2014-08-21 08:42:45 -0600 )edit

ubuntu 12.04.

rajcoumar gravatar imagerajcoumar ( 2014-08-21 22:52:33 -0600 )edit

What is virsh version ?

dbaxps gravatar imagedbaxps ( 2014-08-21 23:27:05 -0600 )edit

i didnt install nova-network on compute node... only nova-compute-kvm package installed

rajcoumar gravatar imagerajcoumar ( 2014-08-22 00:19:12 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-08-21 09:00:00 -0600

dbaxps gravatar image

updated 2014-08-21 09:06:04 -0600

Please, run on compute node command virsh like this :-

[root@icehouse1 ~(keystone_admin)]# virsh
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # version
Compiled against library: libvirt 1.1.1
Using library: libvirt 1.1.1
Using API: QEMU 1.1.1
Running hypervisor: QEMU 1.5.3

root@ubuntusrv0820:~# virsh
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # version
Compiled against library: libvirt 1.2.2
Using library: libvirt 1.2.2
Using API: QEMU 1.2.2
Running hypervisor: QEMU 2.0.0


    It will show you version of Libvirt installed.
edit flag offensive delete link more

Comments

virsh # version

Compiled against library: libvirt 1.1.1

Using library: libvirt 1.1.1

Using API: QEMU 1.1.1

Running hypervisor: QEMU 1.5.0

rajcoumar gravatar imagerajcoumar ( 2014-08-22 00:05:05 -0600 )edit
0

answered 2014-08-21 12:15:47 -0600

Diego Lima gravatar image

Make sure your compute nodes and API server are running the same version of Nova packages.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-21 08:38:39 -0600

Seen: 961 times

Last updated: Aug 21 '14