Ask Your Question
0

keystone Failed to start the admin server

asked 2014-08-21 06:40:24 -0500

sledge gravatar image

Recently when I run keystone-all command I receive

keystone-all
2014-08-21 07:28:32.731 2320 WARNING keystone.openstack.common.versionutils [-] Deprecated: keystone.middleware.core.XmlBodyMiddleware is deprecated as of Icehouse in favor of support for "application/json" only and may be removed in K.
2014-08-21 07:28:32.751 2320 ERROR root [-] Failed to start the admin server
2014-08-21 07:28:32.751 2320 TRACE root Traceback (most recent call last):
2014-08-21 07:28:32.751 2320 TRACE root   File "/usr/bin/keystone-all", line 79, in serve
2014-08-21 07:28:32.751 2320 TRACE root     server.start()
2014-08-21 07:28:32.751 2320 TRACE root   File "/usr/lib/python2.7/dist-packages/keystone/common/environment/eventlet_server.py", line 66, in start
2014-08-21 07:28:32.751 2320 TRACE root     backlog=backlog)
2014-08-21 07:28:32.751 2320 TRACE root   File "/usr/lib/python2.7/dist-packages/eventlet/convenience.py", line 38, in listen
2014-08-21 07:28:32.751 2320 TRACE root     sock.bind(addr)
2014-08-21 07:28:32.751 2320 TRACE root   File "/usr/lib/python2.7/socket.py", line 224, in meth
2014-08-21 07:28:32.751 2320 TRACE root     return getattr(self._sock,name)(*args)
2014-08-21 07:28:32.751 2320 TRACE root error: [Errno 98] Address already in use
2014-08-21 07:28:32.751 2320 TRACE root 
2014-08-21 07:28:32.751 2320 CRITICAL keystone [-] error: [Errno 98] Address already in use

but netstat shows that it's listening on the admin port and I can use keystone to authenticate on swift.

Maybe I misunderstood something, when I start keystone

service keystone start

I have no error and I also see it's listening on the admin port, is the error message comes from the fact that keystone is already running or there is something wrong with my keystone installation ?

regards

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-08-21 09:16:02 -0500

Already running

edit flag offensive delete link more

Comments

Yeah you already have the process running and need to either stop it, if that doesn't work then kill it, or don't try to run a new instance if there were not edits to the keystone.conf.

mpetason gravatar imagempetason ( 2014-08-21 10:11:24 -0500 )edit
0

answered 2014-08-21 10:39:56 -0500

sledge gravatar image

thank you both for your answers.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-21 06:40:24 -0500

Seen: 2,247 times

Last updated: Aug 21 '14