Ask Your Question
0

Problem nova-network

asked 2013-08-28 00:20:07 -0500

cedric gravatar image

Hello, I've a problem when I start the openstack-nova-network service in my compute node. I lose the network connection in the compute node ( I can't connect with SSH neither ping google from the compute node) here's my log from /var/log/nova/network.log

 tail /var/log/nova/network.log
2013-08-28 08:41:16.783 9995 CRITICAL nova [-] Unexpected error while running command.
Command: sudo nova-rootwrap /etc/nova/rootwrap.conf ip route add default via x.x.x.x (my ip)
Exit code: 2
Stdout: ''
Stderr: 'RTNETLINK answers: No such process\n'
2013-08-28 09:05:39.387 2429 CRITICAL nova [-] Unexpected error while running command.
Command: sudo nova-rootwrap /etc/nova/rootwrap.conf ip route add default via x.x.x.x (my ip)
Exit code: 2
Stdout: ''
Stderr: 'RTNETLINK answers: No such process\n'
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-22 08:06:14 -0500

fnawaz gravatar image

I think ip route add default via x.x.x.x command should be given in interfaces file .. then try to restart the services

edit flag offensive delete link more

Comments

Could you please share the location of the "interfaces file" and the exact steps on how to fix this. I am observing the same error when creating a new Compute instance.

Henry Lawson gravatar imageHenry Lawson ( 2016-03-08 00:15:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-28 00:20:07 -0500

Seen: 380 times

Last updated: Aug 28 '13