Ask Your Question
0

Openstack console issue

asked 2014-08-19 06:11:19 -0500

MIB gravatar image

Hi, nothing coming on instance console....openstack havana multi node.... VM is spawing up properly but nothing getting displayed.... All services & agents are running.......

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-08-21 10:42:39 -0500

mpetason gravatar image

updated 2014-08-21 10:43:17 -0500

This requires more information. Are you using custom Images or are you using images provided by the community? If they are not configured to output to the console then the console will be empty. You can verify this with:

nova console-log {instance-uuid}

If it is a configuration issue with nova.conf then you can verify the configuration and see why you are unable to hit the endpoint that is listening for novnc. You will need to point the nova.conf proxy address over to the controller:

novncproxy_base_url=http://{controller-ip}:6080/vnc_auto.html

Also keep in mind that the controller IP address you are using needs to be route-able from your location. If you can't hit the IP from your desktop then you aren't going to be able to view the console as it is just displaying information from that address. When you select it in full screen mode you are pulling up the IP address specified in the nova.conf file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-19 06:11:19 -0500

Seen: 197 times

Last updated: Aug 21 '14