Ask Your Question
0

CentOS 6.5 with packstack ? odds of working ?

asked 2014-08-18 21:08:39 -0500

FredSmite gravatar image

updated 2014-08-18 21:45:43 -0500

What are the odds of packstack working on CentOS system ?

edit retag flag offensive close merge delete

Comments

192.168.1.140_keystone.pp: [ ERROR ]
Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.1.140_keystone.pp Error: Could not start Service[keystone]: Execution of '/sbin/service openstack-keystone start' returned 1: Starting keystone: [FAILED] You will find full trace in log /var/tmp/packstack/20140818-213542-0QT2KJ/manifests/192.168.1.140_keystone.pp.log Please check log file /var/tmp/packstack/20140818-213542-0QT2KJ/openstack-setup.log for more information

FredSmite gravatar imageFredSmite ( 2014-08-18 21:44:52 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-08-18 23:40:14 -0500

Anand TS gravatar image

Hello,

This error cause because you have run packstack command multiple times. Here your keystone service is already running . Try to stop your keystone service and also check the packstack answer file generated that matches the existing keystone setup and rerun packstack using that answer file.

edit flag offensive delete link more

Comments

Follow your advice doing AIO install on Fedora 20 and get on next run via answer-file :-

192.169.142.127_keystone.pp:                      [ ERROR ]            
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.169.142.127_keystone.pp
Error: /Stage[main]/Keystone::Roles::Admin/Keystone_role[_member_]: Could not evaluate: Execution of '/usr/bin/keystone --os-endpoint http://127.0.0.1:35357/v2.0/ role-list' returned 1: An unexpected error prevented the server from fulfilling your request. (HTTP 500)
You will find full trace in log /var/tmp/packstack/20140819-105156-nV0geY/manifests/192.169.142.127_keystone.pp.log
dbaxps gravatar imagedbaxps ( 2014-08-19 02:19:44 -0500 )edit
1

Hi

I solved this error. It was due to having old devstack present on the system . I have to remove /opt/stack

FredSmite gravatar imageFredSmite ( 2014-08-19 07:20:45 -0500 )edit

Can u plz tell me how did u removed this error.Did u uninstall the dev stack then how ?Plz elaborate how did u solved this error.

Queen gravatar imageQueen ( 2014-11-27 21:19:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-08-18 21:08:39 -0500

Seen: 194 times

Last updated: Aug 18 '14