Ask Your Question
1

Unable to set password on istance

asked 2014-08-18 11:06:12 -0500

asd gravatar image

Hi all, i cannot change the password of an instance through the relative nova api /v2/{tenant_id}/servers/{server_id}/action. I installed devstack on a dedicated hardware and i get an http error "code": "501", "message": "Unable to set password on istance". I read that the operation may be available depending on virtual layer of choice, but i don't know what it means. Thanks in advance for your help!

edit retag flag offensive close merge delete

Comments

beni gravatar imagebeni ( 2014-08-20 04:20:55 -0500 )edit

can you be specific in your answer.

SGPJ gravatar imageSGPJ ( 2014-08-20 04:39:55 -0500 )edit

Unfortunately not as I just stumbled upon this documentation some days ago without trying it out myself. So, do you think a comment would be better than an answer?

beni gravatar imagebeni ( 2014-08-20 04:45:26 -0500 )edit

Ok, I will follow this guidelines the next time, thanks for converting to a comment this time.

beni gravatar imagebeni ( 2014-08-20 06:26:51 -0500 )edit

I have QEMU hypervisor and in fact, in /etc/nova/nova.conf there isn't, in [libvirt], inject_password = true. I try to put it in this file but i receive always the same HTTP error code: "501", message: "Unable to set password on istance". The image i used to build the server is Fedora-x86_64.

asd gravatar imageasd ( 2014-08-20 08:21:12 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-08-21 10:33:23 -0500

mpetason gravatar image

The comment before was accurate. You'll want to take a look at:

http://docs.openstack.org/admin-guide...

Besides that you'll need to consider a couplethings:

Most Images are setup by default to not allow password based logins. If this is the case with the image you are using then you will need to modify the sshd config before you can login with the password.

What use case do you have where an SSH key is not sufficient for accessing the machine?So most of the images you will receive expect an ssh key which you can setup through OpenStack. It injects the key and you can ssh to the instance with the user@ and use the key.

Anyways, modify the setting in nova.conf. It doesn't specify but it says Hypervisors so you'll want to do this on the compute nodes. You may want to do it on the controllers as well just to have consistency. After you modify the setting in nova.conf restart nova-compute on the compute nodes. If you edit it on the controllers then you'll need to go through and restart Nova services there first.

After that modify : local_settings, which can be in either of the locations specified in the guide. You'll make the change in there then restart apache. Depending on your version of Linux it could be apache2 or httpd.

Then try to modify the password again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-18 11:06:12 -0500

Seen: 1,045 times

Last updated: Aug 21 '14