Ask Your Question
1

Creating Windows 7 template to upload to Grizzly

asked 2013-04-23 09:28:38 -0500

ThiagoCMC gravatar image

updated 2013-07-16 18:34:56 -0500

smaffulli gravatar image

Hi!

With Folsom, I used to create a Windows 7 image, with KVM+libvirt and then, uploading it to Glance with the following command:

glance image-create --name "Windows 7 - ULTIMATE - 32 Bits - Pre-Installed Image" --is-public true --container-format bare --disk-format qcow2 < /home/openstack/windows7-template.img

But now, when I repeat this process in Grizzly, the Windows Instance doesn't complete its boot, a Windows Message appear on VNC console:

 "System Recovery Options"

I choose: "Start up repair", doesn't work... I'm trying everything but, doesn't work.

Also, I created this `Windows 7 Template' using exactly the same options of openstack instance, by dumping the instance-xxxxx.xml file and using to create the template in first place. So, the virtual CPU is the same, video board, etc...

What am I missing?

Thanks! Thiago

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
1

answered 2013-05-10 21:56:17 -0500

fifieldt gravatar image

updated 2013-07-17 00:35:49 -0500

Hi,

The documentation team recently produced an VM Image Guide to help with these sorts of issues.

http://docs.openstack.org/trunk/openstack-image/content/

has a section on "Creating a Windows Image" that might be able to shed some light.

edit flag offensive delete link more

Comments

With an image created as the above link steps, the Win 7 image can be loaded by glance and launched with an instance. It boots OK, but the IE/Chrome browser can not get any web pages to appear, except bing web. They are all pinned OK. With Ubuntu desktop, the browser shows other webs fine. Any hint?

MMC gravatar imageMMC ( 2015-02-02 16:24:08 -0500 )edit
1

answered 2013-08-30 01:59:34 -0500

Anand TS gravatar image

I launched windows instance in openstack. The issue with booting (System recovery options) was due to the inappropiate installation of VirtIO drivers. We need to install both redhat ethernet adapter driver as well as red-hat scsi driver in the image before launching. Try this method.

edit flag offensive delete link more
1

answered 2013-07-17 06:15:10 -0500

Arminder S Girgla gravatar image

Are you using a virtio bus type image in KVM+libvirt? If not, you need to create one with bus type as virtio instead of ide/sata/scsi and add the virtio drivers from iso image at http://alt.fedoraproject.org/pub/alt/virtio-win/latest/. Make sure you choose network type too as virtio.

  • Arminder
edit flag offensive delete link more
0

answered 2013-08-22 00:50:45 -0500

Anand TS gravatar image

Hi Thiago,

Is your problem solved??

I have exactly the same issue that Windows Instance doesn't complete its boot while using grizzly, a Windows Message appear on VNC console:

'System recovery options'.

If you find a solution already, kindly share as for this issue I have been trying to launch windows instance for past two weeks.

I have launched windows2012 using the cloud image from microsoft site. but problem with windows2KR2 and windows7 instance.

Thanks & Regards, Anand

edit flag offensive delete link more
0

answered 2013-08-22 03:32:05 -0500

Bhavaniprasad gravatar image

try to change the --disk-format qcow2 to --disk-format raw

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-04-23 09:28:38 -0500

Seen: 1,691 times

Last updated: Aug 22 '13