hello ineed help to resolve this mistake. [closed]

asked 2014-08-18 04:43:38 -0500

oumar_syr gravatar image

updated 2014-08-18 09:13:09 -0500

SamYaple gravatar image
root@snugb-srv02:~# glance add name="Ubuntu 12.04 cloudimg amd64" is_public=true container_format=bare disk_format=qcow2 < ubuntu-12.04-server-cloudimg-amd64-disk1.img 
===================================================================================================================================[100%] 496.236409M/s, ETA  0h  0m  0s
Failed to add image. Got error:
An object with the specified identifier was not found.
Details: 404 Not Found

The resource could not be found.

Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'.
edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by smaffulli
close date 2014-08-18 10:07:34.705003


did you try also with glance image-create ?

T u l gravatar imageT u l ( 2014-08-18 06:18:51 -0500 )edit

yeah i've tried it but it returns me the same message

oumar_syr gravatar imageoumar_syr ( 2014-08-18 06:43:22 -0500 )edit
T u l gravatar imageT u l ( 2014-08-18 07:31:18 -0500 )edit

Agreed with T u l

Verify your endpoint is correct keystone endpoint-list

SamYaple gravatar imageSamYaple ( 2014-08-18 09:14:00 -0500 )edit

thank you there were a mistake in my endpoint-list but it returns me when i add the image:

Failed to add image. Got error: The request returned a 302 Multiple Choices. This generally means that you have not included a version indicator in a request URI.

The body of response returned: {"versions": [{"status": "CURRENT", "id": "v1.1", "links": [{"href": "", "rel": "self"}]}, {"status": "SUPPORTED", "id": "v1.0", "links": [{"href": "", "rel": "self"}]}]}

oumar_syr gravatar imageoumar_syr ( 2014-08-18 09:43:27 -0500 )edit