Ask Your Question
0

Fixed (private) IP addressing missing after packstack --allinone install.

asked 2014-08-17 19:40:19 -0500

FredSmite gravatar image

After a packstack --allinone Single node install I can launch a VM successfully now but it only receives a public IP address of 72,24.x.x

 <code>    nova list

+--------------------------------------+------+--------+------------+-------------+---------------------+ | ID | Name | Status | Task State | Power State | Networks | +--------------------------------------+------+--------+------------+-------------+---------------------+ | 3bc37dfa-ea75-4621-b3ec-d0ec9ff3d359 | demo | ACTIVE | - | Running | public=172.24.4.233 |


Shouldn't I see a private address ? 10.0.0.x too ?

I can't login to the instance:

 nova secgroup-list-rules default
+-------------+-----------+---------+-----------+--------------+
| IP Protocol | From Port | To Port | IP Range  | Source Group |
+-------------+-----------+---------+-----------+--------------+
| icmp        | -1        | -1      | 0.0.0.0/0 |              |
|             |           |         |           | default      |
|             |           |         |           | default      |
| tcp         | 22        | 22      | 0.0.0.0/0 |              |

ssh -i .ssh/mykeys.pem root@172.24.4.233

fails

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-08-17 22:37:51 -0500

dbaxps gravatar image

updated 2014-08-19 06:11:54 -0500

Yes you should see private address.
My previous suggestion is working version on CentOS 7, I was able to perform AIO RDO install on Fedora 20 completely functional with plugin.ini.

   [root@icehouse neutron(keystone_admin)]# cat plugin.ini | grep -v ^$ | grep -v ^#
    [ml2]
    type_drivers = vxlan
    tenant_network_types = vxlan
    mechanism_drivers =openvswitch
    [ml2_type_flat]
    [ml2_type_vlan]
    [ml2_type_gre]
    [ml2_type_vxlan]
    vni_ranges =10:100
    vxlan_group =224.0.0.1
    [securitygroup]
    enable_security_group = True

[OVS] section is not required on F20, I apologize for trouble caused by my previous feed.
However, adding [OVS] section on F20 is harmless, it doesn't crash neutron server or affect AIO instance functionality in any other way

[OVS]
local_ip=192.168.1.127
enable_tunneling=True
integration_bridge=br-int
tunnel_bridge=br-tun


[boris@icehouse Downloads]$ ping -c 3 192.168.122.151
PING 192.168.122.151 (192.168.122.151) 56(84) bytes of data.
64 bytes from 192.168.122.151: icmp_seq=1 ttl=63 time=1.52 ms
64 bytes from 192.168.122.151: icmp_seq=2 ttl=63 time=0.386 ms
64 bytes from 192.168.122.151: icmp_seq=3 ttl=63 time=0.527 ms

--- 192.168.122.151 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 0.386/0.813/1.527/0.508 ms
[boris@icehouse Downloads]$ ssh -i oskey25.pem cirros@192.168.122.151
$ uname -a
Linux cirros 3.2.0-37-virtual #58-Ubuntu SMP Thu Jan 24 15:48:03 UTC 2013 x86_64 GNU/Linux
$ curl http://169.254.169.254/latest/meta-data/local-ipv4
10.0.0.3$ 
$ ifconfig
eth0      Link encap:Ethernet  HWaddr FA:16:3E:07:FB:CF  
          inet addr:10.0.0.3  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::f816:3eff:fe07:fbcf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:398 errors:0 dropped:0 overruns:0 frame:0
          TX packets:336 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:100613 (98.2 KiB)  TX bytes:36035 (35.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
edit flag offensive delete link more

Comments

I was forced to use answer field due to leak of formatting text option in comment fields.

dbaxps gravatar imagedbaxps ( 2014-08-17 23:45:18 -0500 )edit

I am trying to figure out the proper way to post here since the text gets mangled.

FredSmite gravatar imageFredSmite ( 2014-08-18 06:56:50 -0500 )edit
  1. Why wasn;t this set up with packstack ?
  2. integration_bridge=br-int suppose to point to br-ex bridge device ?
  3. my plugin is missing firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver - Do I need to set that too ?
  4. I guess I have to reboot - Or there is a way to re-init neutron ?
FredSmite gravatar imageFredSmite ( 2014-08-18 07:31:47 -0500 )edit

Tune sample for your box and use exactly as posted ( RH's packstack bug fixed). Reboot the box for order of services restarted.

dbaxps gravatar imagedbaxps ( 2014-08-18 07:45:25 -0500 )edit

I did :

[root@gibsonsg neutron]# grep -v "#" plugin.ini 
[ml2]
type_drivers = vxlan

tenant_network_types = vxlan

mechanism_drivers =openvswitch

[ml2_type_flat]

[ml2_type_vlan]

[ml2_type_gre]

[ml2_type_vxlan]
vni_ranges =10:100
[OVS]
local_ip=192.168.1.126
enable_tunneling=True
integration_bridge=br-int
tunnel_bridge=br-tun

vxlan_group =224.0.0.1

[securitygroup]
enable_security_group = True

Now the dashboard no longer works .

FredSmite gravatar imageFredSmite ( 2014-08-18 08:02:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-17 19:40:19 -0500

Seen: 322 times

Last updated: Aug 19 '14