Ask Your Question
1

Open vSwitch agent status failed

asked 2014-08-17 09:56:42 -0600

RHK gravatar image

updated 2014-08-17 10:08:36 -0600

dbaxps gravatar image

Hello All,

I am having havana single node ovs setup, i am using ubuntu 12.04.3 server with Linux ubuntu 3.8.0-44-generic #66~precise1-Ubuntu SMP Tue Jul 15 04:01:04 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux.

I am facing the below issue,

root@ubuntu:~# neutron agent-list
+--------------------------------------+--------------------+--------+-------+----------------+
| id                                   | agent_type         | host   | alive | admin_state_up |
+--------------------------------------+--------------------+--------+-------+----------------+
| 60b79b93-22ad-4cc1-9e70-9573a5c6cbba | L3 agent           | ubuntu | :-)   | True           |
| 995c8cb9-5666-4832-ac31-f19b5cbb8a5c | Open vSwitch agent | ubuntu | xxx   | True           |
| b9a85efb-2fe3-4b07-a4ca-96af8edb6593 | DHCP agent         | ubuntu | :-)   | True           |
| c2329a7a-9bcb-4ff5-951c-a29ca63d0e87 | Open vSwitch agent | ubuntu | xxx   | True           |
+--------------------------------------+--------------------+--------+-------+----------------+

Here is the openvswitch logs,

root@ubuntu:/var/log/neutron# **tail -f openvswitch-agent.log**
Exit code: 1
Stdout: ''
Stderr: 'Device "br-int" does not exist.\n'
2014-08-17 05:46:07.840 21648 CRITICAL neutron [-]
Command: ['ip', '-o', 'link', 'show', 'br-int']
Exit code: 1
Stdout: ''
Stderr: 'Device "br-int" does not exist.\n'
2014-08-17 06:52:41.797 1850 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 3.57817 sec
2014-08-17 06:53:18.435 1850 WARNING neutron.openstack.common.loopingcall [-] task run outlasted interval by 3.707205 sec

But i created br-int bridge,

root@ubuntu:~# ovs-vsctl show
8c77e497-99a5-49d6-901e-fbab22c1ee76
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth0"
            Interface "eth0"
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    ovs_version: "1.10.2"

Help me to fix this issue.

Regards, RHK

edit retag flag offensive close merge delete

Comments

Your neutron agent-list looks bad:-
Two copies of Open vSwitch agent on the same host
Please, post /etc/neutron/plugin.ini,/etc/neutron/metadata_agent.ini
ps -ef | grep neutron-
in other words I need list of all neutron services running

dbaxps gravatar imagedbaxps ( 2014-08-17 10:23:02 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-08-17 11:06:36 -0600

RHK gravatar image

updated 2014-08-17 11:08:49 -0600

Hi dbaxps,

Here is the more information,

root@ubuntu:~# vim /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini

[ovs]

tenant_network_type = gre enable_tunneling = True tunnel_id_ranges = 1:1000 integration_bridge = br-int tunnel_bridge = br-tun local_ip = 10.10.10.51

[securitygroup] firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[DATABASE] sql_connection=mysql://neutron:openstacktest@10.10.10.51/neutron

==================================================================

root@ubuntu:/etc/neutron# vim metadata_agent.ini

[DEFAULT]

auth_url = http://10.10.10.51:35357/v2.0 auth_region = RegionOne admin_tenant_name = service admin_user = neutron admin_password = openstacktest

nova_metadata_ip = 10.10.10.51

nova_metadata_port = 8775

metadata_proxy_shared_secret = helloOpenStack

==========================================================

root@ubuntu:~# ps -ef | grep neutron-

neutron 1833 1 0 07:11 ? 00:00:10 /usr/bin/python /usr/bin/neutron-dhcp-agent --config-file=/etc/neutron/neutron.conf --config-file=/etc/neutron/dhcp_agent.ini --log-file=/var/log/neutron/dhcp-agent.log neutron 1841 1 0 07:11 ? 00:00:01 /usr/bin/python /usr/bin/neutron-metadata-agent --config-file=/etc/neutron/neutron.conf --config-file=/etc/neutron/metadata_agent.ini --log-file=/var/log/neutron/metadata-agent.log neutron 1847 1 0 07:11 ? 00:00:17 /usr/bin/python /usr/bin/neutron-l3-agent --config-file=/etc/neutron/neutron.conf --config-file=/etc/neutron/l3_agent.ini --log-file=/var/log/neutron/l3-agent.log neutron 1850 1 0 07:11 ? 00:00:57 /usr/bin/python /usr/bin/neutron-openvswitch-agent --config-file=/etc/neutron/neutron.conf --config-file=/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini --log-file=/var/log/neutron/openvswitch-agent.log neutron 1866 1 0 07:11 ? 00:00:59 /usr/bin/python /usr/bin/neutron-server --config-file /etc/neutron/neutron.conf --log-file /var/log/neutron/server.log --config-file /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini root 24136 6701 0 09:03 pts/2 00:00:00 grep --color=auto neutron-

===========================================

root@ubuntu:~# cd /etc/init.d/; for i in $( ls neutron-* ); do sudo service $i status; cd /root/; done

neutron-dhcp-agent start/running, process 24332 neutron-l3-agent start/running, process 24360 neutron-metadata-agent start/running, process 24369 neutron-plugin-openvswitch-agent start/running, process 24378 neutron-server start/running, process 24387

Regards, RHK

edit flag offensive delete link more

Comments

Please, make updates to your answer field and format output . To make it possible to read.
Does your iptables contain rows
-A INPUT -p gre -j ACCEPT
-A OUTPUT -p gre -j ACCEPT
[root@icehouse1 neutron(keystone_admin)]# netstat -lntp | grep 9696
tcp 0 0 0.0.0.0:9696 0.0.0.0:* LISTEN 1581/python

[root@icehouse1 neutron(keystone_admin)]# ps -ef | grep 1581
neutron 1581 1 0 12:49 ? 00:01:23 /usr/bin/python /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --log-file /var/log/neutron/server.log

dbaxps gravatar imagedbaxps ( 2014-08-17 11:46:19 -0600 )edit

Just in case ( IceHouse Bug) https://ask.openstack.org/en/question...

dbaxps gravatar imagedbaxps ( 2014-08-17 12:02:05 -0600 )edit

root@ubuntu:~# netstat -lntp | grep 9696 tcp 0 0 0.0.0.0:9696 0.0.0.0:* LISTEN 24387/python FYI

root@ubuntu:~# ps -ef | grep 1581 root 47919 6701 0 11:13 pts/2 00:00:00 grep --color=auto 1581

RHK gravatar imageRHK ( 2014-08-17 13:17:57 -0600 )edit

i am using havana

RHK gravatar imageRHK ( 2014-08-17 13:18:51 -0600 )edit

i modified in neutron.conf

agent_down_time = 75 report_interval=30

but same issue.

RHK gravatar imageRHK ( 2014-08-17 13:19:40 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-17 09:56:42 -0600

Seen: 1,616 times

Last updated: Aug 17 '14