Ask Your Question
1

packstack issue centos 7

asked 2014-08-15 14:27:21 -0500

Prosperent gravatar image

Been going through issues one by one trying to get this to work. Haven't figured this one out yet:

    Installing Dependencies                              [ DONE ]
Copying Puppet modules and manifests                 [ DONE ]
Applying xx.xx.51.200_prescript.pp
Applying 192.168.1.200_prescript.pp
xx.xx.51.200_prescript.pp:                           [ DONE ]
192.168.1.200_prescript.pp:                          [ DONE ]
Applying 192.168.1.200_amqp.pp
192.168.1.200_amqp.pp:                               [ DONE ]
Applying xx.xx.51.200_keystone.pp
Applying xx.xx.51.200_glance.pp
Applying xx.xx.51.200_cinder.pp
xx.xx.51.200_keystone.pp:                         [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: xx.xx.xx.xx_keystone.pp
Error: Syntax error at ','; expected '}' at /var/tmp/packstack/e6b0dac2765c4e31b93323de44e13ebd/modules/mysql/manifode monitor01.prosperent.com
You will find full trace in log /var/tmp/packstack/20140815-130805-qYbpIC/manifests/xx.xx.xxx.xx_keystone.pp.log
Please check log file /var/tmp/packstack/20140815-130805-qYbpIC/openstack-setup.log for more information

Checking the log gives me this:

[1;31mWarning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
Error: Syntax error at ','; expected '}' at /var/tmp/packstack/1283ad3946de4c1cbc1a465cfe153fc1/modules/mysql/manifests/params.pp:42 on node monitor01.prosperent.com
Error: Syntax error at ','; expected '}' at /var/tmp/packstack/1283ad3946de4c1cbc1a465cfe153fc1/modules/mysql/manifests/params.pp:42 on node monitor01.prosperent.com

It appears that there is a syntax error somewhere, but I can't figure out where it might be.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-08-16 08:34:31 -0500

dbaxps gravatar image

If you followed https://ask.openstack.org/en/question...
most probably you made an error applying patch

/usr/share/openstack-puppet/modules/mysql/manifests/params.pp: line 40:
<        'RedHat': {
<          if $::operatingsystemrelease >= 7 {
>        'RedHat','CentOS': {
>          if $::operatingsystemmajrelease >= 7 {
edit flag offensive delete link more
1

answered 2014-08-15 15:22:54 -0500

Prosperent gravatar image

I "think" the issue was a file edit I did previously for another workaround that I found somewhere else. https://ask.openstack.org/en/question/35705/attempt-of-rdo-aio-install-icehouse-on-centos-7/ (https://ask.openstack.org/en/question...)

It's getting difficult keeping track of all of the changes and hacks.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-15 14:27:21 -0500

Seen: 482 times

Last updated: Aug 16 '14