Ask Your Question
0

Trove: Error: Unauthorized SSL23_GET_SERVER_HELLO:unknown protocol

asked 2014-08-15 09:53:14 -0500

beni gravatar image

updated 2014-08-15 09:53:27 -0500

I installed OpenStack Icehouse on Scientific Linux 6 using Packstack. Then I followed the OpenStack documentation to setup Trove.

Now, if as OpenStack user admin I run trove list or trove datastore-list or click on Databases > Database Instances within Horizon I get ERROR: Unauthorized in case of the CLI and […] An unexpected error has occurred l…] in case of Horizon. Trove log shows

WARNING keystoneclient.middleware.auth_token [-] Retrying on HTTP connection exception: [Errno 1] _ssl.c:492: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
 WARNING keystoneclient.middleware.auth_token [-] Authorization failed for token
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2014-08-15 09:55:03 -0500

beni gravatar image

updated 2014-08-15 10:02:40 -0500

HTTPS is default for the keystone client, so add the following to trove.conf, trove-conductor.conf, trove-taskmanager.conf, trove-guestagent.conf (see https://bugs.launchpad.net/devstack/+... ):

[keystone_authtoken]
auth_protocol = http

Of course it would be better to switch to HTTPS completely, at the latest when going to production.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-15 09:53:14 -0500

Seen: 982 times

Last updated: Aug 15 '14