Ask Your Question
1

Network connectivity issue

asked 2014-08-13 11:56:37 -0500

JohnSmith gravatar image

updated 2014-08-14 02:04:55 -0500

Hi,

Im following this guide 1.) to set up Red Hat RDO packstack openstack with an existing network. It says to use the current ip of your eth0 interface for the br-ex device instead and remove it from eth0. But when I do this, I get weird connectivity issues where even a single ping to the default gateway fails 95% of the time, but not always: some pings come through alright. A simple network restart or reboot does not change anything.

The problem (temporarily) goes away (but returns later) when I use a previously unused ip in the same range for the br-ex device, but I wonder what the issue could be ? Could it be as simple as an arp cache entry somewhere (my internet cable modem ?) or something ?

Ive added the contents of ifcfg-br-ex and ifcfg-eth0, and the output of 'ovs-vsctl show'

1.) http://openstack.redhat.com/Neutron_with_existing_external_network (http://openstack.redhat.com/Neutron_w...)

# cat /etc/sysconfig/network-scripts/ifcfg-br-ex
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=none
IPADDR=192.168.178.27 # Old eth0 IP since we want the network restart to not kill the connection, otherwise pick something outside your dhcp range
NETMASK=255.255.255.0  # your netmask
GATEWAY=192.168.178.1  # your gateway
DNS1=192.168.178.1     # your nameserver
ONBOOT=yes

# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
HWADDR=00:0C:29:5E:C4:5D
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
ONBOOT=yes

# ovs-vsctl show
c418fb29-4fb4-45ae-a3b4-ea86ff356135
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth0"
            Interface "eth0"
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    ovs_version: "1.11.0"
edit retag flag offensive close merge delete

Comments

Could you post ifcfg-br-ex and ifcfg-eth0. Also output ovs-vsctl show

dbaxps gravatar imagedbaxps ( 2014-08-13 12:19:35 -0500 )edit

You wrote :-

GATEWAY=192.168.178.1  # your gateway
DNS1=192.168.178.1     # your nameserver
Is 192.168.178.1 your real DNS Server ?
dbaxps gravatar imagedbaxps ( 2014-08-14 02:32:12 -0500 )edit

Yes 192.168.178.1 is functioning as the DNS server for the network.

JohnSmith gravatar imageJohnSmith ( 2014-08-14 06:54:07 -0500 )edit

Would try
# tcpdump -vv -i br-ex
during pinging gateway. Issue should be caught via (-vv)

dbaxps gravatar imagedbaxps ( 2014-08-14 07:19:19 -0500 )edit

Also, it only happens if I run 'packstack --allinone --provision-all-in-one-ovs-bridge=n' and manually edit the ifcfg files, and not if i omit the '--provision-all-in-one-ovs-bridge=n'' and just run 'packstack --allinone'. I guess thats because when you run packstack that way, it doenst attempt to modify your existing network ?

When I run packstack like that, I get this :

# ovs-vsctl show
bb042af4-1628-404e-8f5f-c8249a31a5a2
    Bridge br-int
        fail_mode: secure
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qr-f2f2be7d-2e"
            tag: 1
            Interface "qr-f2f2be7d-2e"
                type: internal
        Port br-int
            Interface br-int
                type: internal
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "qg-47249854-44"
            Interface "qg-47249854-44"
                type: internal
    ovs_version: "1.11.0"

# neutron net-list
+--------------------------------------+---------+------------------------------------------------------+
| id                                   | name    | subnets                                              |
+--------------------------------------+---------+------------------------------------------------------+
| b614a425-42fd-4623-aed6-5084dcf9b0a8 | private | 29319c25-d5bf-4a73-a53e-a0a614509833 10.0.0.0/24     |
| 52a4c4bf-31fa-42c6-ba04-2cc4711ff0e3 | public  | 34ffc759-4d68-44fa-96ce-6165d9e52f31 172.24.4.224/28 |
+--------------------------------------+---------+------------------------------------------------------+
JohnSmith gravatar imageJohnSmith ( 2014-08-16 01:39:54 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-08-14 01:14:24 -0500

Do you have any external firewall? Please check with firewall also.

edit flag offensive delete link more
0

answered 2014-08-14 01:13:20 -0500

dbaxps gravatar image

Have you configured ifcfg-br-ex and end ifcfg-eth0 as follows, where 192.168.1.135 previous IP of eth0.
Disable NetworkManager and enable service network. Create files under /etc/sysconfig/network-scripts

[root@openstack network-scripts(keystone_admin)]# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="192.168.1.135"
NETMASK="255.255.255.0"
DNS1="83.221.202.254"
BROADCAST="192.168.1.255"
GATEWAY="192.168.1.1"
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSBridge"
DEVICETYPE="ovs"

In my particular case ifcfg-eth0 was responsible for active ethernet interface eth0.

[root@openstack network-scripts(keystone_admin)]# cat ifcfg-eth0
DEVICE="eth0"
# HWADDR=90:E6:BA:2D:11:EB
ONBOOT="yes"
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE=br-ex
NM_CONTROLLED=no
IPV6INIT=no

# service network restart
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-08-13 11:56:37 -0500

Seen: 365 times

Last updated: Aug 14 '14