How to fix Error appeared during Puppet run: Error: mysqladmin -u root password " " returned 1 instead of one of [0]

asked 2014-08-12 20:01:52 -0600

JacobR gravatar image

Hi I was trying to install openstack in CentOs6.4. I am very new to this and I would really appreciate if anyone could provide me a solution to fix this error!!!! I am using Virtual Box through vagrant to manage the Virtual Machine(CentOS)!!!!!!

edit retag flag offensive close merge delete


Usually packstack shows you logfiles you can look at to get more information about the error. After fixing it run packstack again as dbaxps said.

beni gravatar imagebeni ( 2014-08-13 14:36:48 -0600 )edit

As dbaxps mentioned in his answer, the problem might be that the root password for mysql is already set (e.g. by previous installation attempt), and when you run packstack again with no answer file specified, it will generate new answer file, with random mysql root password (which will not work).

T u l gravatar imageT u l ( 2014-08-15 15:27:34 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-08-13 00:35:55 -0600

dbaxps gravatar image

updated 2014-08-15 15:16:12 -0600

Seems like you are running packstack not the first time. After first run answer-file should be left in your home directory like packstack-answers-20140811-130123.txt. Second run

# packstack --answer-file=./packstack-answers-20140811-130123.txt
edit flag offensive delete link more


Aren't there two dashes missing so it will be --answer-file?

beni gravatar imagebeni ( 2014-08-15 14:59:45 -0600 )edit

Yes, packstack --answer-file=./packstack-answers-20140811-130123.txt
I fixed typo in answer field.

dbaxps gravatar imagedbaxps ( 2014-08-15 15:14:58 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2014-08-12 20:01:52 -0600

Seen: 628 times

Last updated: Aug 15 '14