Ask Your Question
1

nova-compute connecting amqp local

asked 2014-08-12 11:47:09 -0500

bobyakov gravatar image

Hi Guys,

Need some help with nova compute. Seems I can't get nova-compute to register with controller. Everything else is working properly. I checked the logs on compute node, and only error I see is in nova-compute. Although below error indicated AMQP as localhost:5672, my config is actually a clustered rabbitmq server. I am able to telnet and connect on said port. No idea why it keeps trying localhost.

Using Ubuntu 14.04 and Openstack icehouse

nova-compute log:

2014-08-12 12:32:26.659 4173 INFO oslo.messaging._drivers.impl_rabbit [-] Reconnecting to AMQP server on localhost:5672
2014-08-12 12:32:26.659 4173 INFO oslo.messaging._drivers.impl_rabbit [-] Delaying reconnect for 1.0 seconds...
2014-08-12 12:32:27.673 4173 ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on localhost:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 23 seconds.
2014-08-12 12:32:50.691 4173 INFO oslo.messaging._drivers.impl_rabbit [-] Reconnecting to AMQP server on localhost:5672
2014-08-12 12:32:50.692 4173 INFO oslo.messaging._drivers.impl_rabbit [-] Delaying reconnect for 1.0 seconds...
2014-08-12 12:32:51.705 4173 ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on localhost:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 25 seconds.
2014-08-12 12:33:16.725 4173 INFO oslo.messaging._drivers.impl_rabbit [-] Reconnecting to AMQP server on localhost:5672
2014-08-12 12:33:16.726 4173 INFO oslo.messaging._drivers.impl_rabbit [-] Delaying reconnect for 1.0 seconds...
2014-08-12 12:33:17.738 4173 ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on localhost:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 27 seconds.

compute node nova.conf:

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata
auth_strategy = keystone
glance_host = 10.1.0.2

[database]
# The SQLAlchemy connection string used to connect to the database
connection = mysql://nova:password@10.1.0.2/nova

[keystone_authtoken]
auth_uri = http://10.1.0.2:5000
auth_host = 10.1.0.2
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = password

[rabbitMQ]
rpc_backend = rabbit
rabbit_hosts = 10.1.0.5,10.1.0.6
rabbit_password = password

[neutron network]
network_api_class = nova.network.neutronv2.api.API
neutron_url = http://10.1.0.2:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = quantum
neutron_admin_password = password
neutron_admin_auth_url = http://10.1.0.2:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
security_group_api = neutron

my_ip = 10.1.0.22
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.1.0.22
novncproxy_base_url = http://10.1.0.2:6080/vnc_auto.html
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-08-14 08:38:18 -0500

bobyakov gravatar image

Moved rabbitMQ setting from Rabbitmq section to default section in nova.conf on compute node and communication started working.

edit flag offensive delete link more

Comments

thanks. It Works for Me, Too (Openstack Kilo)

Saleh Havid gravatar imageSaleh Havid ( 2015-07-03 08:05:26 -0500 )edit

@bobyakov , Could you tell me how to move rabbitMQ setting from Rabbitmq section to default section in nova.conf....

neelabhsingh gravatar imageneelabhsingh ( 2015-09-01 02:39:07 -0500 )edit

In nova config there are sections identified by brackets. Example [DEFAULT] then the next section would be [database] you need to make sure each configuration entry is written in the correct section. Open stack documentation clarifies which section each config option goes to.

bobyakov gravatar imagebobyakov ( 2015-09-01 06:48:04 -0500 )edit
0

answered 2014-08-12 13:27:01 -0500

achutha gravatar image

In the above config file you configured two rabbitmq hosts only one needed and it can be run in any of services of openstack or it can be run on the other node vm also

edit flag offensive delete link more

Comments

I thought since I am running rabbitmq cluster, I need to specify both? Also, will it impact functionality if I mention both? Lastly, other services are configured the same way and work.

bobyakov gravatar imagebobyakov ( 2014-08-12 14:17:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-12 11:47:09 -0500

Seen: 6,901 times

Last updated: Aug 14 '14